Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3606 closed defect (duplicate)

FFmpeg fails to stream copy TS into TS with AAC sometimes

Reported by: ramitbhalla Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: aac mpegts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug: With some TS files I've found this error, no able to wrap my head around why it's unable to remux this back into a TS.

It errors out with:
AAC bitstream not in ADTS format and extradata missing

How to reproduce:

ffmpeg -i ts.ts -vcodec copy -acodec copy test.ts
ffmpeg version N-62897-g0f9f24c Copyright (c) 2000-2014 the FFmpeg developers
  built on May  1 2014 23:29:04 with gcc 4.8.0 (GCC)
  configuration: --arch=x86 --target-os=mingw32 --cross-prefix=/home/mcebuddy/Software/ffmpeg/sandbox/mingw-w64-i686/bin
/i686-w64-mingw32- --pkg-config=pkg-config --enable-hwaccels --enable-dxva2 --enable-gpl --enable-libx264 --enable-avisy
nth --enable-libxvid --enable-libmp3lame --enable-version3 --enable-zlib --enable-librtmp --enable-libvorbis --enable-li
btheora --enable-libspeex --enable-libopenjpeg --enable-gnutls --enable-libgsm --enable-libfreetype --enable-libopus --d
isable-w32threads --enable-frei0r --enable-filter=frei0r --enable-libvo-aacenc --enable-bzlib --enable-libxavs --extra-c
flags=-DPTW32_STATIC_LIB --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libvo-amrwbenc --enable-libschro
edinger --enable-libvpx --enable-libilbc --prefix=/home/mcebuddy/Software/ffmpeg/sandbox/mingw-w64-i686/i686-w64-mingw32
 --enable-static --disable-shared --enable-libsoxr --enable-fontconfig --enable-libass --enable-libutvideo --enable-libb
luray --enable-iconv --enable-libtwolame --extra-cflags=-DLIBTWOLAME_STATIC --enable-libzvbi --enable-libcaca --enable-l
ibmodplug --extra-libs=-lstdc++ --extra-libs=-lpng --enable-libvidstab --extra-cflags= --extra-cflags= --enable-nonfree
--enable-libfdk-aac --enable-libfaac --enable-runtime-cpudetect
  libavutil      52. 80.100 / 52. 80.100
  libavcodec     55. 60.103 / 55. 60.103
  libavformat    55. 37.102 / 55. 37.102
  libavdevice    55. 13.100 / 55. 13.100
  libavfilter     4.  5.100 /  4.  5.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
[aac @ 0358cc40] channel element 1.0 is not allocated
[mpeg2video @ 035234a0] Invalid frame dimensions 0x0.
[aac @ 03523d20] channel element 2.6 is not allocated
[mpeg2video @ 035234a0] Invalid frame dimensions 0x0.
    Last message repeated 3 times
[NULL @ 03557b60] non-existing PPS 1 referenced
    Last message repeated 1 times
[h264 @ 03557b60] non-existing PPS 1 referenced
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[h264 @ 03557b60] non-existing PPS 1 referenced
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[mpeg2video @ 035234a0] Invalid frame dimensions 0x0.
    Last message repeated 6 times
[h264 @ 03557b60] non-existing PPS 1 referenced
    Last message repeated 3 times
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[h264 @ 03557b60] non-existing PPS 1 referenced
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[h264 @ 03557b60] non-existing PPS 1 referenced
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[mpeg2video @ 035234a0] Invalid frame dimensions 0x0.
    Last message repeated 1 times
[mpegts @ 03524e40] PES packet size mismatch
    Last message repeated 3 times
[mpegts @ 03524e40] probed stream 2 failed
[h264 @ 03557b60] non-existing PPS 1 referenced
    Last message repeated 3 times
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[h264 @ 03557b60] non-existing PPS 1 referenced
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[h264 @ 03557b60] non-existing PPS 1 referenced
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[h264 @ 03557b60] non-existing PPS 1 referenced
    Last message repeated 1 times
[h264 @ 03557b60] decode_slice_header error
[h264 @ 03557b60] no frame!
[mpegts @ 03524e40] PES packet size mismatch
[mpegts @ 03524e40] Could not find codec parameters for stream 2 (Unknown: none ([6][0][0][0] / 0x0006)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 3 (Unknown: none ([6][0][0][0] / 0x0006)): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 4 (Unknown: none ([13][0][0][0] / 0x000D)): unknown codec

Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 5 (Unknown: none ([13][0][0][0] / 0x000D)): unknown codec

Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 6 (Unknown: none ([13][0][0][0] / 0x000D)): unknown codec

Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 7 (Unknown: none ([13][0][0][0] / 0x000D)): unknown codec

Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 8 (Unknown: none ([13][0][0][0] / 0x000D)): unknown codec

Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 9 (Unknown: none ([13][0][0][0] / 0x000D)): unknown codec

Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 10 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 13 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 14 (Unknown: none ([6][0][0][0] / 0x0006)): unknown codec

Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 15 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 16 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 17 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 18 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 19 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 20 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 21 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 22 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 23 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 24 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 25 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 26 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 27 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 28 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 29 (Unknown: none ([13][0][0][0] / 0x000D)): unknown code
c
Consider increasing the value for the 'analyzeduration' and 'probesize' options
[mpegts @ 03524e40] Could not find codec parameters for stream 30 (Unknown: none): unknown codec
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, mpegts, from 'ts.ts':
  Duration: 00:00:01.79, start: 81095.631189, bitrate: 11451 kb/s
  Program 1032
    Metadata:
      service_name    : ?NHKE?F?l1?El5~
      service_provider:
    Stream #0:0[0x100]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv, bt709), 1440x1080 [SAR 4:3 DAR 16:
9], max. 24000 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0:1[0x110]: Audio: aac ([15][0][0][0] / 0x000F), 48000 Hz, stereo, fltp, 257 kb/s
    Stream #0:2[0x130]: Unknown: none ([6][0][0][0] / 0x0006)
    Stream #0:3[0x138]: Unknown: none ([6][0][0][0] / 0x0006)
    Stream #0:4[0x140]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:5[0x160]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:6[0x161]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:7[0x162]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:8[0x163]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:9[0x164]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:10[0x165]: Unknown: none ([13][0][0][0] / 0x000D)
  Program 1033
    Metadata:
      service_name    : ?NHKE?F?l2?El5~
      service_provider:
    Stream #0:0[0x100]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv, bt709), 1440x1080 [SAR 4:3 DAR 16:
9], max. 24000 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0:1[0x110]: Audio: aac ([15][0][0][0] / 0x000F), 48000 Hz, stereo, fltp, 257 kb/s
    Stream #0:2[0x130]: Unknown: none ([6][0][0][0] / 0x0006)
    Stream #0:3[0x138]: Unknown: none ([6][0][0][0] / 0x0006)
    Stream #0:4[0x140]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:5[0x160]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:6[0x161]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:7[0x162]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:8[0x163]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:9[0x164]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:10[0x165]: Unknown: none ([13][0][0][0] / 0x000D)
  Program 1034
    Metadata:
      service_name    : ?NHKE?F?l3?El5~
      service_provider:
    Stream #0:0[0x100]: Video: mpeg2video (Main) ([2][0][0][0] / 0x0002), yuv420p(tv, bt709), 1440x1080 [SAR 4:3 DAR 16:
9], max. 24000 kb/s, 29.97 fps, 29.97 tbr, 90k tbn, 59.94 tbc
    Stream #0:1[0x110]: Audio: aac ([15][0][0][0] / 0x000F), 48000 Hz, stereo, fltp, 257 kb/s
    Stream #0:2[0x130]: Unknown: none ([6][0][0][0] / 0x0006)
    Stream #0:3[0x138]: Unknown: none ([6][0][0][0] / 0x0006)
    Stream #0:4[0x140]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:5[0x160]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:6[0x161]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:7[0x162]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:8[0x163]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:9[0x164]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:10[0x165]: Unknown: none ([13][0][0][0] / 0x000D)
  Program 1416
    Metadata:
      service_name    : ?NHK?7HBS?2
      service_provider:
    Stream #0:13[0x580]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:11[0x581]: Video: h264 (Constrained Baseline) ([27][0][0][0] / 0x001B), yuv420p, 320x180, 7.50 fps, 29.97
tbr, 90k tbn, 14.99 tbc
    Stream #0:12[0x583]: Audio: aac ([15][0][0][0] / 0x000F), 48000 Hz, stereo, fltp, 56 kb/s
    Stream #0:14[0x587]: Unknown: none ([6][0][0][0] / 0x0006)
    Stream #0:15[0x589]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:16[0x58a]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:17[0x58b]: Unknown: none ([13][0][0][0] / 0x000D)
  Program 65521
    Stream #0:18[0x1d71]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:19[0x1d72]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:20[0x1d73]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:21[0x1d74]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:22[0x1d75]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:23[0x1d76]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:24[0x1d77]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:25[0x1d78]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:26[0x1c60]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:27[0x1c61]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:28[0x1c62]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:29[0x1c63]: Unknown: none ([13][0][0][0] / 0x000D)
    Stream #0:30[0x238]: Unknown: none
Output #0, mpegts, to 'test.ts':
  Metadata:
    encoder         : Lavf55.37.102
    Stream #0:0: Video: mpeg2video ([2][0][0][0] / 0x0002), yuv420p, 1440x1080 [SAR 4:3 DAR 16:9], q=2-31, max. 24000 kb
/s, 29.97 fps, 90k tbn, 29.97 tbc
    Stream #0:1: Audio: aac ([15][0][0][0] / 0x000F), 48000 Hz, stereo, 257 kb/s
Stream mapping:
  Stream #0:0 -> #0:0 (copy)
  Stream #0:1 -> #0:1 (copy)
Press [q] to stop, [?] for help
[mpegts @ 04074800] AAC bitstream not in ADTS format and extradata missing
av_interleaved_write_frame(): Invalid data found when processing input
frame=    1 fps=0.0 q=-1.0 Lsize=      95kB time=00:00:00.62 bitrate=1255.4kbits/s
video:72kB audio:16kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 8.215266%
Conversion failed!

Attaching the sample

Attachments (1)

#3606.ts (2.4 MB) - added by ramitbhalla 5 years ago.

Change History (6)

Changed 5 years ago by ramitbhalla

comment:1 Changed 5 years ago by cehoyos

  • Keywords aac mpegts added
  • Resolution set to duplicate
  • Status changed from new to closed
  • Summary changed from FFMPEg fails to stream copy TS into TS with AAC sometimes to FFmpeg fails to stream copy TS into TS with AAC sometimes

Looks like a duplicate of ticket #279, please test again once that is fixed!

comment:2 follow-up: Changed 5 years ago by ramitbhalla

I'm using a build that's 2 days old:
built on May 1 2014

Obviously it's a retrogression in that case

comment:3 Changed 5 years ago by ramitbhalla

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:4 in reply to: ↑ 2 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from reopened to closed

Replying to ramitbhalla:

I'm using a build that's 2 days old:
built on May 1 2014

Obviously it's a retrogression in that case

If you believe this is a regression, please provide at least a working command line including the complete, uncut console output (or the change introducing the regression).

comment:5 Changed 5 years ago by ramitbhalla

My apologies, I misread your comment. I thought it has been fixed and you asked me to retest it.

Though i'm surprised, this has been open for years now.

Note: See TracTickets for help on using tickets.