Opened 5 years ago

Closed 5 years ago

#3538 closed defect (fixed)

image is outside the screen dimensions

Reported by: hackPNZ Owned by:
Priority: normal Component: avcodec
Version: git-master Keywords: gif
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
GIF conversion error: image is outside the screen dimensions.

How to reproduce:

ffmpeg -i test_blonde.gif test.webm
ffmpeg version N-62122-g16509d3 Copyright (c) 2000-2014 the FFmpeg developers
  built on Apr  4 2014 13:30:32 with gcc 4.6.3 (GCC) 20120306 (Red Hat 4.6.3-2)
  configuration: --enable-libvpx
  libavutil      52. 73.100 / 52. 73.100
  libavcodec     55. 56.107 / 55. 56.107
  libavformat    55. 36.101 / 55. 36.101
  libavdevice    55. 11.100 / 55. 11.100
  libavfilter     4.  3.100 /  4.  3.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 18.100 /  0. 18.100
Input #0, gif, from 'test_blonde.gif':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: gif, bgra, 640x533, 25 fps, 100 tbr, 100 tbn, 100 tbc
[libvpx @ 0x238ce40] v1.3.0
Output #0, webm, to 'test.webm':
  Metadata:
    encoder         : Lavf55.36.101
    Stream #0:0: Video: vp8 (libvpx), yuva420p, 640x533, q=-1--1, 200 kb/s, 1k tbn, 100 tbc
Stream mapping:
  Stream #0:0 -> #0:0 (gif -> libvpx)
Press [q] to stop, [?] for help
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.7 bitrate= 526.4kbits/s
Error while decoding stream #0:0: Invalid data found when processing input
[gif @ 0x238b480] image is outside the screen dimensions.
Error while decoding stream #0:0: Invalid data found when processing input
frame=   11 fps=8.6 q=0.0 Lsize=      55kB time=00:00:01.17 bitrate= 385.1kbits/s
video:54kB audio:0kB subtitle:0kB other streams:0kB global headers:0kB muxing overhead: 1.240338%

Attachments (1)

patchgifwidth (826 bytes) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (11)

comment:2 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords gif added
  • Reproduced by developer set
  • Status changed from new to open

For future tickets: Please only use external libraries (like libvpx) if they are needed to reproduce the problem. Always using internal codecs makes reproducing issues much easier.

left + width is 641 for some frames (actual screen width 640), at least some players support such files.

Changed 5 years ago by cehoyos

comment:3 Changed 5 years ago by hackPNZ

Thanks for your response!

I think I understood the problem, but is it possible to convert such GIFs? Because, at least in browsers the GIF seems to be ok and animation is playing without any artifacts and issues.

Version 0, edited 5 years ago by hackPNZ (next)

comment:4 follow-up: Changed 5 years ago by cehoyos

Attached patch is unfortunately not completely correct but does not show artefacts or do I misunderstand?

comment:5 in reply to: ↑ 4 Changed 5 years ago by hackPNZ

Replying to cehoyos:

Attached patch is unfortunately not completely correct but does not show artefacts or do I misunderstand?

Thank you so much, I tested ffmpeg with your patch (build last commit from master) and result seems to be great! What about the patch? As I understood, at the moment it's hotfix and not production-ready? Do you plan to include this fix to some future ffmpeg release?

comment:6 follow-up: Changed 5 years ago by cehoyos

If you watch the right border and the window in the background closely (and compare with your web browser), you will see that the patch is not correct.

comment:7 in reply to: ↑ 6 Changed 5 years ago by hackPNZ

Replying to cehoyos:

If you watch the right border and the window in the background closely (and compare with your web browser), you will see that the patch is not correct.

Ohh, has been looking the image and the video and saw the problem... But thanks anyway! So do you plan to fix that issue later?

comment:8 Changed 5 years ago by kurosu

Test file no longer available, can someone attach it here or upload it to the usual samples subfolder?

comment:10 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Christophe Gisquet in 4ddb3a6d

Note: See TracTickets for help on using tickets.