Opened 5 years ago

Closed 5 years ago

#3523 closed defect (fixed)

ffprobe bit_rate wrong with -prefix

Reported by: sfrenkiel Owned by:
Priority: important Component: ffprobe
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

Run the following:
ffprobe -show_format -unit http://samples.mplayerhq.hu/A-codecs/MP3/Silent_Light.mp3

Note the output includes:
bit_rate=128000 bit/s

now run:
ffprobe -show_format -unit -prefix http://samples.mplayerhq.hu/A-codecs/MP3/Silent_Light.mp3

And note the output contains:
bit_rate=128000 Kbit/s

The output should be:
bit_rate=128.0 Kbit/s

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to ffprobe
  • Keywords regression added
  • Priority changed from minor to important
  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from ffprobe 2.2 bit_rate wrong when -prefix used to ffprobe bit_rate wrong with -prefix
  • Version changed from unspecified to git-master

Regression since 5e99a23b

For future reports: Please always provide a failing command line together with the complete, uncut console output.

$ ffprobe -show_format -prefix Silent_Light.mp3
ffprobe version N-62054-gf359bac Copyright (c) 2007-2014 the FFmpeg developers
  built on Apr  3 2014 00:49:12 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl
  libavutil      52. 71.100 / 52. 71.100
  libavcodec     55. 56.107 / 55. 56.107
  libavformat    55. 36.101 / 55. 36.101
  libavdevice    55. 11.100 / 55. 11.100
  libavfilter     4.  3.100 /  4.  3.100
  libswscale      2.  6.100 /  2.  6.100
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
[mp3 @ 0x300c240] Estimating duration from bitrate, this may be inaccurate
Input #0, mp3, from 'Silent_Light.mp3':
  Metadata:
    artist          : ÷ÉÓÏËÏÓÎÙÊ ÇÏÄ
    title           : ôÉÈÉÊ ÏÇÏÎÅË
  Duration: 00:04:22.92, start: 0.000000, bitrate: 128 kb/s
    Stream #0:0: Audio: mp3, 44100 Hz, stereo, s16p, 128 kb/s
[FORMAT]
filename=Silent_Light.mp3
nb_streams=1
nb_programs=0
format_name=mp3
format_long_name=MP2/3 (MPEG audio layer 2/3)
start_time=0.000000
duration=262.920000
size=4.206720 M
bit_rate=128000 K
probe_score=51
TAG:artist=÷ÉÓÏËÏÓÎÙÊ ÇÏÄ
TAG:title=ôÉÈÉÊ ÏÇÏÎÅË
[/FORMAT]

comment:2 Changed 5 years ago by michael

patch on ML

comment:3 Changed 5 years ago by saste

  • Analyzed by developer set
  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed in:

commit 1ba59b1cbeafe7cd28db04f772abd89eb7e4ce1e
Author: Stefano Sabatini <stefasab@gmail.com>
Date:   Tue Apr 22 13:01:14 2014 +0200

    ffprobe: fix scaling of vali in value_string() in case -prefix is selected
    
    Fix trac ticket #3523.

Thanks for reporting.

Note: See TracTickets for help on using tickets.