Opened 5 years ago

Closed 5 years ago

#35 closed defect (fixed)

--disable-vdpau keeps mpeg1_vdpau and mpeg2_vdpau enabled

Reported by: taeuber Owned by: michael
Priority: normal Component: avcodec
Version: git Keywords: vdpau configure
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

This is so with version from just now:
2011/04/01 -21:52

$ git pull
$ ./configure [...] --disable-vdpau

[...]
Enabled hwaccels:
mpeg1_vdpau             mpeg2_vdpau
[...]

$ LANG=C make
LD      ffmpeg_g
/ffmpeg/ffmpeg/libavcodec/libavcodec.so: undefined reference to `ff_vdpau_mpeg_picture_complete'
/ffmpeg/ffmpeg/libavcodec/libavcodec.so: undefined reference to `ff_mpeg2_vdpau_hwaccel'
/ffmpeg/ffmpeg/libavcodec/libavcodec.so: undefined reference to `ff_mpeg1_vdpau_hwaccel'
collect2: ld returned 1 exit status
make: *** [ffmpeg_g] Error 1

How do I get to know the version of the pulled source? Isn't there a tag or something like that?

Thanks
Lars

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from new to closed

This should be fixed (or at least worked-around) in latest git HEAD.

Thank you for the report!

Note: See TracTickets for help on using tickets.