Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3498 closed defect (worksforme)

FFmpeg hangs when recording internet radio AAC stream

Reported by: Marcin Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: AAC
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
I'm trying to record internet radio stream. It happens almost always during first ten minutes that ffmpeg hangs. Process is running at very low cpu usage, but nothing is written to output file. Output from ffmpeg (terminated with SIG_INT) in the attached file.

Output of ps -C ffmpeg -o state,pcpu,rss,vsize,nwchan,thcount,args

S %CPU   RSS    VSZ  WCHAN THCNT COMMAND
S  0.4  6584  68388 ffffff     5 ./ffmpeg -i http://10113.live.streamtheworld.com:80/SUPER_FMAAC_SC -acodec mp3 stream.mp3 -v 9 -loglevel 99

How to reproduce:

% ./ffmpeg -i http://10113.live.streamtheworld.com:80/SUPER_FMAAC_SC -acodec mp3 stream.mp3 -v 9 -loglevel 99
ffmpeg version: master a81ee2651fafd4412d0f8df159a3a11f6365ba70
built on Ubuntu 12.04.4 with kernel 3.2.0-60-generic-pae

Attachments (1)

ffmpeg.log (5.2 KB) - added by Marcin 5 years ago.
Output from running ffmpeg process

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by Marcin

Output from running ffmpeg process

comment:1 Changed 5 years ago by Marcin

  • Summary changed from FFmpeg hangs when recording internet stream to FFmpeg hangs when recording internet radio AAC stream

comment:2 Changed 5 years ago by cehoyos

  • Component changed from ffmpeg to undetermined

(Generally, please avoid using external libraries when reporting problems with FFmpeg except if the problem is directly related to the external library: Please use ac3, mp2, pcm or another native encoder.)

I cannot reproduce the issue here (recording works fine, I assume this depends on the network quality), please try to record the original stream from the network (for example with mplayer -dumpstream and if the recorded file allows to reproduce the issue, upload the sample.

Or to say it differently: I am not surprised about the issue (similar bugs were fixed in the past iirc) but without a sample, I don't think this can be fixed.

comment:3 Changed 5 years ago by cehoyos

I recorded 15,5 hours but I am unable to reproduce any problem with the resulting stream.

comment:4 Changed 5 years ago by Marcin

  • Resolution set to wontfix
  • Status changed from new to closed

We were experiencing this issue for a few days. Now I cannot reproduce the problem so probably it was related, as you suggested, to network issues. I think we can close the ticket.

comment:5 Changed 5 years ago by cehoyos

  • Resolution changed from wontfix to worksforme
Note: See TracTickets for help on using tickets.