Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3478 closed enhancement (fixed)

jpegls: support palettized 8bpp

Reported by: ami_stuff Owned by:
Priority: wish Component: avcodec
Version: git-master Keywords: jpegls
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

saved with hp plugin:

http://www.hpl.hp.com/research/info_theory/loco/downdll.htm

C:\>ffmpeg -i 8bpp_palette.jls
ffmpeg version N-61570-gaa86ccc Copyright (c) 2000-2014 the FFmpeg developers
  built on Mar 17 2014 22:01:34 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aa
cenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavp
ack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable
-zlib
  libavutil      52. 67.100 / 52. 67.100
  libavcodec     55. 52.102 / 55. 52.102
  libavformat    55. 34.101 / 55. 34.101
  libavdevice    55. 11.100 / 55. 11.100
  libavfilter     4.  3.100 /  4.  3.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
[jpegls @ 02dd2620] palette not supported
Input #0, image2, from '8bpp_palette.jls':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0:0: Video: jpegls, gray, 1024x768, 25 tbr, 25 tbn, 25 tbc
At least one output file must be specified

Attachments (1)

8bpp_palette.jls (490.4 KB) - added by ami_stuff 4 years ago.

Download all attachments as: .zip

Change History (5)

Changed 4 years ago by ami_stuff

comment:1 Changed 4 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords jpegls added
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open
  • Type changed from defect to enhancement
  • Version changed from unspecified to git-master

comment:2 follow-up: Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Michael in 254f653b

comment:3 in reply to: ↑ 2 ; follow-up: Changed 4 years ago by ami_stuff

Replying to cehoyos:

Fixed by Michael in 254f653b

Thanks, but it looks like HP plugin can decode attached sample with colors while FFmpeg/CharLS only in grayscale?

comment:4 in reply to: ↑ 3 Changed 4 years ago by michael

Replying to ami_stuff:

Replying to cehoyos:

Fixed by Michael in 254f653b

Thanks, but it looks like HP plugin can decode attached sample with colors while FFmpeg/CharLS only in grayscale?

should be fixed

Note: See TracTickets for help on using tickets.