Opened 4 years ago

Closed 4 years ago

#3452 closed defect (fixed)

mpegts (h264) fails parsing AUs

Reported by: FernetMenta Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mpegts h264
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have been carrying this sample for quite a while in my issues folder because I thought it was a faulty sample.
https://dl.dropboxusercontent.com/u/47522966/sampleInterlaced.ts

Playing it with XBMC (ffmpeg master branch) this results in stutter caused by missing frames from demuxer. pts coming out from decoder look like this:

12:35:25 T:140089427441408 DEBUG: CPullupCorrection: detected pattern of length 32: 33366.33 33366.67 33367.00 33366.33 33366.67 33367.00 33366.33 33366.67 33367.00 33366.33 33366.67 33367.00 33366.33 33366.67 33367.00 33366.33 33366.67 33367.00 33366.33 33366.67 33367.00 33366.33 33366.67 150144.67 -83411.33 33366.67 33367.00 150144.00 33367.00 33366.67 33366.33 33367.00, frameduration: 37015.968750

Playing the same sample through my vnsi demuxer/parser used for live tv (https://github.com/FernetMenta/xbmc-pvr-addons/blob/vnsi5/addons/pvr.vdr.vnsi/vdr-plugin-vnsiserver/parser_h264.c) results in clean timestamps:
12:36:04 T:140089256535808 DEBUG: CPullupCorrection: detected pattern of length 1: 33366.67, frameduration: 33366.666667

Change History (2)

comment:1 Changed 4 years ago by FernetMenta

  • Version changed from unspecified to git-master

comment:2 Changed 4 years ago by cehoyos

  • Keywords h264 added
  • Resolution set to fixed
  • Status changed from new to closed

Fixed by Michael in 1e5271a9
Probably a duplicate of ticket #2143.

Note: See TracTickets for help on using tickets.