Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3448 closed defect (invalid)

problem when seeking with an mp4 file

Reported by: galkahana Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
i am trying to created a version of seg_2_1_1.mp4 without the first half a second.
i am running the command "ffmpeg -y -i seg_2_1_1.mp4 -ss 0.5 -c copy seg_2_1_1_cut.mp4" to do this.
problem is the result is wrong. Seems like too much video is cut.
Checking with ffprobe i see that the output streams are desynched - the video stream is
shorter than the audio stream in about half a second, and is offset by 0.6 seconds.
i would like NOT to lose that extra half a second.

for some reason, when encoding, even just the video stream, doing something like this:
"ffmpeg -y -i seg_2_1_1.mp4 -ss 0.5 -c:a copy seg_2_1_1_cut.mp4"
The problem is solved. however, this takes more time, so i'd like to avoid.

How to reproduce:

% ffmpeg -y -i seg_2_1_1.mp4 -ss 0.5 -c copy seg_2_1_1_cut.mp4
ffmpeg version N-61105-gbba7b6f
built on  Mar  5 2014 22:01:31 with gcc 4.8.2

Attachments (4)

seg_2_1_1.mp4 (1.9 MB) - added by galkahana 5 years ago.
original mp4 file
seg_2_1_1_cut.mp4 (1.5 MB) - added by galkahana 5 years ago.
result mp4 file
seg_2_1_1.mp4.json (3.5 KB) - added by galkahana 5 years ago.
ffprobe output for original file
seg_2_1_1_cut.mp4.json (3.3 KB) - added by galkahana 5 years ago.
ffprobe output for result file

Change History (6)

Changed 5 years ago by galkahana

original mp4 file

Changed 5 years ago by galkahana

result mp4 file

Changed 5 years ago by galkahana

ffprobe output for original file

Changed 5 years ago by galkahana

ffprobe output for result file

comment:1 Changed 5 years ago by cehoyos

  • Keywords seek mp4 removed
  • Resolution set to invalid
  • Status changed from new to closed

The first GOP of your input stream has 33 frames (1.1 seconds), you cannot cut less frames with -vcodec copy.

For future tickets: Please do not attach output file or json output (unless requested), always provide your failing command line together with the complete, uncut console output (you only provided the command line).

comment:2 Changed 5 years ago by galkahana

mishap of mine (had the console output here). thanks a lot!

Note: See TracTickets for help on using tickets.