Opened 4 years ago

Closed 4 years ago

Last modified 4 years ago

#3446 closed defect (needs_more_info)

ffmpeg.exe crash on windows 32 bits

Reported by: kriss0013 Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: crash win32
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

problem is in libavutil 52 on instruction av_buffer_pool_get, this problem appears after ffmpeg was uploaded to version 2.0 and after superior version. The problem appears on av_decode_video2 function when first image is correctly decoded.
This problem doesn't exist in version 1.x.x

I reproduced this problem with ffmpeg.exe (see attached files)

my windows version is compiled using mingw 4.4.5 under linux redhat

Attachments (4)

test2.JPG (236.2 KB) - added by kriss0013 4 years ago.
test1.JPG (349.8 KB) - added by kriss0013 4 years ago.
test_ffmpeg_win32.log (5.1 KB) - added by kriss0013 4 years ago.
test_ffmpeg_win64.log (279.0 KB) - added by kriss0013 4 years ago.

Download all attachments as: .zip

Change History (10)

Changed 4 years ago by kriss0013

Changed 4 years ago by kriss0013

comment:1 Changed 4 years ago by cehoyos

  • Keywords crash added; av_buffer_pool_get removed
  • Version changed from 2.0.3 to git-master

Please provide the input sample ParkingBezon?-FAT.MPEG4.avi or post the necessary information for a bug report here as explained on http://ffmpeg.org/bugreports.html

Changed 4 years ago by kriss0013

Changed 4 years ago by kriss0013

comment:2 Changed 4 years ago by kriss0013

add two command line with ffmpeg on win32 and win64 to see it works on win 64 bits and have problem on win 32 bits.

comment:3 Changed 4 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can either provide your input sample or the necessary information for crash reports (backtrace, disassembly and register content) as explained on http://ffmpeg.org/bugreports.html

comment:4 Changed 4 years ago by kriss0013

i uploaded (http://uptobox.com/0mq1b0eq7759) a example with three different version of ffmpeg.
I launch the same test ffmpeg.exe on windows 32 bits. It works with ffmpeg version inferior as 2.0 (1.1.8 and 1.2) and failed after (2.0.4) .
In the archive there are four directory (=> install/win32/bin) have result of test.
each test has a result file called (test_with_ffmpeg_* in directory bin). the video video.mkv is the result for input ParkingBezon?-FAT.MPEG4.avi.

Best regards

comment:5 Changed 4 years ago by cehoyos

I downloaded http://ffmpeg.zeranoe.com/builds/win32/static/ffmpeg-20140311-git-9a05e8a-win32-static.7z and tested the following command line successfully with your sample:

$ md5sum.exe ParkingBezon-FAT.MPEG4.avi
dda72d192f708b5c772dc0c2c4a03247 *ParkingBezon-FAT.MPEG4.avi
$ ffmpeg.exe ParkingBezon-FAT.MPEG4.avi out.mkv

Please also test a recent Zeranoe build.
If the problem is only reproducible with your own build, please test without libx264 to find a possible cause for the crash you see.

comment:6 Changed 4 years ago by kriss0013

I upgrading my cross compiler version to 4.9.0 and it's solved my problem with ffmpeg.exe in windows 32 bits

Note: See TracTickets for help on using tickets.