Opened 5 years ago

Closed 5 years ago

#3441 closed defect (duplicate)

Wrong duration of VOB files

Reported by: mrskman Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have a VOB file, where I need to read it's duration and ffmpeg says it has duration over 90000 seconds. Correct value should be between 800-900 seconds.

It seems to me that problem is in the file itself but is ffmpeg able to handle this situation?

After some investigation I found that problem is somewhere in the end of file. When I cut last ~15 MB, problem is gone.

Here are 2 samples (only last megabytes):
http://www.datafilehost.com/d/b525d8f6
http://www.datafilehost.com/d/4c198bb5

ffmpeg started on 2014-03-06 at 17:27:23
Report written to "ffmpeg-20140306-172723.log"
Command line:
./ffmpeg-latest/bin/ffmpeg -v 9 -loglevel 99 -report -i ./wrong_duration_detected.vob
ffmpeg version git-2014-03-06-d168729 Copyright (c) 2000-2014 the FFmpeg developers
  built on Mar  6 2014 16:57:39 with gcc 4.6 (Ubuntu/Linaro 4.6.3-1ubuntu5)
  configuration: --prefix=/opt/ffmpeg-latest/build --extra-cflags=-I/opt/ffmpeg-latest/build/include --extra-ldflags=-L/opt/ffmpeg-latest/build/lib --bindir=/opt/ffmpeg-latest/bin --extra-libs=-ldl --enable-gpl --enable-libass --enable-libfdk-aac --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopus --enable-libtheora --enable-libvorbis --enable-libvpx --enable-libx264 --enable-nonfree --enable-version3
  libavutil      52. 66.101 / 52. 66.101
  libavcodec     55. 52.102 / 55. 52.102
  libavformat    55. 33.101 / 55. 33.101
  libavdevice    55. 11.100 / 55. 11.100
  libavfilter     4.  3.100 /  4.  3.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 18.100 /  0. 18.100
  libpostproc    52.  3.100 / 52.  3.100
Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '9'.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-report' ... matched as option 'report' (generate a report) with argument '1'.
Reading option '-i' ... matched as input file with argument './wrong_duration_detected.vob'.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option v (set logging level) with argument 9.
Applying option loglevel (set logging level) with argument 99.
Applying option report (generate a report) with argument 1.
Successfully parsed a group of options.
Parsing a group of options: input file ./wrong_duration_detected.vob.
Successfully parsed a group of options.
Opening an input file: ./wrong_duration_detected.vob.
[mpeg @ 0x3ab2a60] Format mpeg probed with size=8192 and score=52
[mpeg @ 0x3ab2a60] Before avformat_find_stream_info() pos: 0 bytes read:32768 seeks:0
[mpeg @ 0x3ab2a60] probing stream 0 pp:2500
[mpeg @ 0x3ab2a60] probing stream 0 pp:2499
[mpeg @ 0x3ab2a60] probing stream 0 pp:2498
[mpeg @ 0x3ab2a60] probing stream 0 pp:2497
[mpeg @ 0x3ab2a60] probing stream 0 pp:2496
[mpeg @ 0x3ab2a60] probing stream 0 pp:2495
[mpeg @ 0x3ab2a60] probing stream 0 pp:2494
[mpeg @ 0x3ab2a60] probing stream 0 pp:2493
[mpeg @ 0x3ab2a60] probing stream 0 pp:2492
[mpeg @ 0x3ab2a60] probing stream 0 pp:2491
[mpeg @ 0x3ab2a60] probing stream 0 pp:2490
[mpeg @ 0x3ab2a60] probing stream 0 pp:2489
[mpeg @ 0x3ab2a60] probing stream 0 pp:2488
[mpeg @ 0x3ab2a60] probing stream 0 pp:2487
[mpeg @ 0x3ab2a60] probing stream 0 pp:2486
[mpeg @ 0x3ab2a60] probing stream 0 pp:2485
[mpeg @ 0x3ab2a60] probing stream 0 pp:2484
[mpeg @ 0x3ab2a60] probing stream 0 pp:2483
[mpeg @ 0x3ab2a60] probing stream 0 pp:2482
[mpeg @ 0x3ab2a60] probing stream 0 pp:2481
[mpeg @ 0x3ab2a60] probing stream 0 pp:2480
[mpeg @ 0x3ab2a60] probing stream 0 pp:2479
[mpeg @ 0x3ab2a60] probing stream 0 pp:2478
[mpeg @ 0x3ab2a60] probing stream 0 pp:2477
[mpeg @ 0x3ab2a60] probing stream 0 pp:2476
[mpeg @ 0x3ab2a60] probing stream 0 pp:2475
[mpeg @ 0x3ab2a60] probing stream 0 pp:2474
[mpeg @ 0x3ab2a60] probing stream 0 pp:2473
[mpeg @ 0x3ab2a60] probing stream 0 pp:2472
[mpeg @ 0x3ab2a60] probing stream 0 pp:2471
[mpeg @ 0x3ab2a60] probing stream 0 pp:2470
[mpeg @ 0x3ab2a60] probing stream 0 pp:2469
[mpeg @ 0x3ab2a60] probing stream 0 pp:2468
[mpeg @ 0x3ab2a60] probing stream 0 pp:2467
[mpeg @ 0x3ab2a60] probing stream 0 pp:2466
[mpeg @ 0x3ab2a60] probing stream 0 pp:2465
[mpeg @ 0x3ab2a60] probing stream 0 pp:2464
[mpeg @ 0x3ab2a60] probing stream 0 pp:2463
[mpeg @ 0x3ab2a60] probing stream 0 pp:2462
[mpeg @ 0x3ab2a60] probing stream 0 pp:2461
[mpeg @ 0x3ab2a60] probing stream 0 pp:2460
[mpeg @ 0x3ab2a60] probing stream 0 pp:2459
[mpeg @ 0x3ab2a60] probing stream 0 pp:2458
[mpeg @ 0x3ab2a60] probing stream 0 pp:2457
[mpeg @ 0x3ab2a60] probing stream 0 pp:2456
[mpeg @ 0x3ab2a60] probing stream 0 pp:2455
[mpeg @ 0x3ab2a60] probing stream 0 pp:2454
[mpeg @ 0x3ab2a60] probing stream 0 pp:2453
[mpeg @ 0x3ab2a60] probing stream 0 pp:2452
[mpeg @ 0x3ab2a60] probing stream 0 pp:2451
[mpeg @ 0x3ab2a60] probing stream 0 pp:2450
[mpeg @ 0x3ab2a60] probing stream 0 pp:2449
[mpeg @ 0x3ab2a60] probing stream 0 pp:2448
[mpeg @ 0x3ab2a60] probing stream 0 pp:2447
[mpeg @ 0x3ab2a60] probing stream 0 pp:2446
[mpeg @ 0x3ab2a60] probing stream 0 pp:2445
[mpeg @ 0x3ab2a60] probing stream 0 pp:2444
[mpeg @ 0x3ab2a60] probing stream 0 pp:2443
[mpeg @ 0x3ab2a60] probing stream 0 pp:2442
[mpeg @ 0x3ab2a60] probing stream 0 pp:2441
[mpeg @ 0x3ab2a60] probing stream 0 pp:2440
[mpeg @ 0x3ab2a60] probing stream 0 pp:2439
[mpeg @ 0x3ab2a60] probing stream 0 pp:2438
[mpeg @ 0x3ab2a60] probing stream 0 pp:2437
[mpeg @ 0x3ab2a60] probing stream 0 pp:2436
[mpeg @ 0x3ab2a60] probing stream 0 pp:2435
[mpeg @ 0x3ab2a60] probing stream 0 pp:2434
[mpeg @ 0x3ab2a60] probing stream 0 pp:2433
[mpeg @ 0x3ab2a60] probing stream 0 pp:2432
[mpeg @ 0x3ab2a60] probing stream 0 pp:2431
[mpeg @ 0x3ab2a60] probing stream 0 pp:2430
[mpeg @ 0x3ab2a60] probing stream 0 pp:2429
[mpeg @ 0x3ab2a60] probing stream 0 pp:2428
[mpeg @ 0x3ab2a60] probing stream 0 pp:2427
[mpeg @ 0x3ab2a60] probing stream 0 pp:2426
[mpeg @ 0x3ab2a60] probing stream 0 pp:2425
[mpeg @ 0x3ab2a60] probing stream 0 pp:2424
[mpeg @ 0x3ab2a60] probing stream 0 pp:2423
[mpeg @ 0x3ab2a60] probing stream 0 pp:2422
[mpeg @ 0x3ab2a60] probing stream 0 pp:2421
[mpeg @ 0x3ab2a60] probing stream 0 pp:2420
[mpeg @ 0x3ab2a60] probing stream 0 pp:2419
[mpeg @ 0x3ab2a60] probing stream 0 pp:2418
[mpeg @ 0x3ab2a60] probing stream 0 pp:2417
[mpeg @ 0x3ab2a60] probing stream 0 pp:2416
[mpeg @ 0x3ab2a60] probing stream 0 pp:2415
[mpeg @ 0x3ab2a60] probing stream 0 pp:2414
[mpeg @ 0x3ab2a60] probing stream 0 pp:2413
[mpeg @ 0x3ab2a60] probing stream 0 pp:2412
[mpeg @ 0x3ab2a60] probing stream 0 pp:2411
[mpeg @ 0x3ab2a60] probing stream 0 pp:2410
[mpeg @ 0x3ab2a60] probing stream 0 pp:2409
[mpeg @ 0x3ab2a60] probing stream 0 pp:2408
[mpeg @ 0x3ab2a60] probing stream 0 pp:2407
[mpeg @ 0x3ab2a60] probing stream 0 pp:2406
[mpeg @ 0x3ab2a60] probing stream 0 pp:2405
[mpeg @ 0x3ab2a60] probing stream 0 pp:2404
[mpeg @ 0x3ab2a60] probing stream 0 pp:2403
[mpeg @ 0x3ab2a60] probing stream 0 pp:2402
[mpeg @ 0x3ab2a60] probing stream 0 pp:2401
[mpeg @ 0x3ab2a60] probing stream 0 pp:2400
[mpeg @ 0x3ab2a60] probing stream 0 pp:2399
[mpeg @ 0x3ab2a60] probing stream 0 pp:2398
[mpeg @ 0x3ab2a60] probing stream 0 pp:2397
[mpeg @ 0x3ab2a60] probing stream 0 pp:2396
[mpeg @ 0x3ab2a60] probing stream 0 pp:2395
[mpeg @ 0x3ab2a60] probing stream 0 pp:2394
[mpeg @ 0x3ab2a60] probing stream 0 pp:2393
[mpeg @ 0x3ab2a60] probing stream 0 pp:2392
[mpeg @ 0x3ab2a60] probing stream 0 pp:2391
[mpeg @ 0x3ab2a60] probing stream 0 pp:2390
[mpeg @ 0x3ab2a60] probing stream 0 pp:2389
[mpeg @ 0x3ab2a60] probing stream 0 pp:2388
[mpeg @ 0x3ab2a60] probing stream 0 pp:2387
[mpeg @ 0x3ab2a60] probing stream 0 pp:2386
[mpeg @ 0x3ab2a60] probing stream 0 pp:2385
[mpeg @ 0x3ab2a60] probing stream 0 pp:2384
[mpeg @ 0x3ab2a60] probing stream 0 pp:2383
[mpeg @ 0x3ab2a60] probing stream 0 pp:2382
[mpeg @ 0x3ab2a60] probing stream 0 pp:2381
[mpeg @ 0x3ab2a60] probing stream 0 pp:2380
[mpeg @ 0x3ab2a60] probing stream 0 pp:2379
[mpeg @ 0x3ab2a60] probing stream 0 pp:2378
[mpeg @ 0x3ab2a60] probing stream 0 pp:2377
[mpeg @ 0x3ab2a60] probing stream 0 pp:2376
[mpeg @ 0x3ab2a60] probing stream 0 pp:2375
[mpeg @ 0x3ab2a60] probing stream 0 pp:2374
[mpeg @ 0x3ab2a60] probing stream 0 pp:2373
[mpeg @ 0x3ab2a60] probing stream 0 pp:2372
[mpeg @ 0x3ab2a60] probing stream 0 pp:2371
[mpeg @ 0x3ab2a60] probing stream 0 pp:2370
[mpeg @ 0x3ab2a60] Probe with size=263701, packets=131 detected mpegvideo with score=51
[mpeg @ 0x3ab2a60] probed stream 0
[mpeg2video @ 0x3ab3a00] Invalid frame dimensions 0x0.
[mpeg2video @ 0x3ab3a00] Invalid frame dimensions 0x0.
[mpeg2video @ 0x3ab3a00] Invalid frame dimensions 0x0.
[mpeg @ 0x3ab2a60] Non-increasing DTS in stream 2: packet 2 with DTS 472903977, packet 3 with DTS 472903977
[mpeg @ 0x3ab2a60] Non-increasing DTS in stream 3: packet 2 with DTS 472903977, packet 3 with DTS 472903977
[mpeg2video @ 0x3ab3a00] Invalid frame dimensions 0x0.
[mpeg2video @ 0x3ab3a00] Invalid frame dimensions 0x0.
[mpeg @ 0x3ab2a60] Non-increasing DTS in stream 0: packet 3 with DTS 9223090561878065151, packet 6 with DTS 9223090561878065151
[mpeg2video @ 0x3ab3a00] Invalid frame dimensions 0x0.
[mpeg2video @ 0x3ab3a00] Invalid frame dimensions 0x0.
[mpeg2video @ 0x3ab3a00] Invalid frame dimensions 0x0.
[mpeg @ 0x3ab2a60] Non-increasing DTS in stream 0: packet 6 with DTS 9223090561878065151, packet 9 with DTS 472917657
[mpeg2video @ 0x3ab3a00] allocate dummy last picture for field based first keyframe
[mpeg @ 0x3ab2a60] max_analyze_duration 5000000 reached at 5024000 microseconds
[mpeg @ 0x3ab2a60] After avformat_find_stream_info() pos: 0 bytes read:3428496 seeks:2 frames:615
Input #0, mpeg, from './wrong_duration_detected.vob':
  Duration: 25:03:24.01, start: 5254.360633, bitrate: 1 kb/s
    Stream #0:0[0x1e0], 128, 1/90000: Video: mpeg2video (Main), yuv420p(tv, bt470bg), 720x576 [SAR 16:15 DAR 4:3], 1/50, max. 8500 kb/s, 25 fps, 50 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x81], 159, 1/90000: Audio: ac3, 48000 Hz, stereo, fltp, 320 kb/s
    Stream #0:2[0x80], 159, 1/90000: Audio: ac3, 48000 Hz, stereo, fltp, 192 kb/s
    Stream #0:3[0x82], 157, 1/90000: Audio: ac3, 48000 Hz, stereo, fltp, 192 kb/s
    Stream #0:4[0x1bf], 12, 1/90000: Data: dvd_nav_packet, 1/90000
Successfully opened the file.
At least one output file must be specified
[AVIOContext @ 0x3abb1e0] Statistics: 3428496 bytes read, 2 seeks

Change History (1)

comment:1 Changed 5 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #2084.

Note: See TracTickets for help on using tickets.