Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3386 closed defect (fixed)

[H264] [Regression] illegal short term buffer state detected

Reported by: Underground78 Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: h264 regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
A regression in H264 decoding was apparently introduced about 3 months ago. It leads to artifacts appearing during playback with "illegal short term buffer state detected" errors being reported in the log.

How to reproduce:
Try this sample in ffplay for example.

>ffplay.exe bbc2.sample.ts
ffplay version N-60646-gd601106 Copyright (c) 2003-2014 the FFmpeg developers
  built on Feb 15 2014 03:11:41 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libx265 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 63.101 / 52. 63.101
  libavcodec     55. 52.101 / 55. 52.101
  libavformat    55. 32.101 / 55. 32.101
  libavdevice    55.  9.101 / 55.  9.101
  libavfilter     4.  1.102 /  4.  1.102
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
[NULL @ 04011580] start time is not set in estimate_timings_from_pts
[mpegts @ 0400d160] PES packet size mismatch
    Last message repeated 1 times
Input #0, mpegts, from 'bbc2.sample.ts':
  Duration: 00:00:47.48, start: 0.200000, bitrate: 8424 kb/s
  Program 1
    Stream #0:0[0x157c]: Video: h264 (High) ([27][0][0][0] / 0x001B), yuv420p(tv
, bt709), 1440x1080 [SAR 4:3 DAR 16:9], 23.75 fps, 25 tbr, 90k tbn, 50 tbc
    Stream #0:1[0x157d](eng): Audio: ac3 ([6][0][0][0] / 0x0006), 48000 Hz, ster
eo, fltp, 192 kb/s
    Stream #0:2[0x157f](eng): Subtitle: dvb_teletext ([6][0][0][0] / 0x0006)
    Stream #0:3[0x1580](eng): Subtitle: dvb_subtitle ([6][0][0][0] / 0x0006)
No codec could be found with id 94215
[h264 @ 054c1980] illegal short term buffer state detected

Attachments (1)

bbc2.sample.h264 (1.7 MB) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 Changed 5 years ago by cehoyos

  • Keywords h264 regression added
  • Priority changed from normal to important

Changed 5 years ago by cehoyos

comment:2 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Reproduced by developer set
  • Status changed from new to open

Regression since 9e5ef1c5

comment:3 Changed 5 years ago by cehoyos

The stream changes between progressive and field encoding:

00045( I )       90    58    18                             4:2:0      57
00043( B )       86    59    24                             4:2:0      46
00042( b )       84    60    24                             4:2:0      37
00044( b )       88    60    24                             4:2:0      41
00049( P )       98    60    22                             4:2:0      52
00047( B )       94    61    23                             4:2:0      51
00046( b )       92    62    24                             4:2:0      40
00048( b )       96    62    23                             4:2:0      46
00053( P )      106    62    20                             4:2:0      54
00051( B )      102    63    22                             4:2:0      61
00050( b )      100     0    24                             4:2:0      52
00052( b )      104     0    23                             4:2:0      56
00057( I )      114     0    18                             4:2:0      68
00055( B )      110     1    24                             4:2:0      59
00054( b )      108     2    25                             4:2:0      52
00056( b )      112     2    25                             4:2:0      53
00061( P )      122     2    22                             4:2:0      66
00059( B )      118     3    24                             4:2:0      62
00058( b )      116     4    25                             4:2:0      53
00060( b )      120     4    24                             4:2:0      57
00065( P | P )  131     4    22                             4:2:0      52
00063( B | B )  127     5    23                             4:2:0      54
00062( b | b )  125     6    24                             4:2:0      46
00064( b | b )  129     6    24                             4:2:0      48
00069( P | P )  139     6    22                             4:2:0      53
00067( B | B )  135     7    23                             4:2:0      56
00066( b | b )  133     8    24                             4:2:0      48
00068( b | b )  137     8    24                             4:2:0      50
00073( P | P )  147     8    22                             4:2:0      55
00071( B | B )  143     9    23                             4:2:0      57
00070( b | b )  141    10    24                             4:2:0      49
00072( b | b )  145    10    24                             4:2:0      51
00075( P | P )  151    10    22                             4:2:0      50
00074( b | b )  149    11    23                             4:2:0      51
00076( I | P )  153    11    16                             4:2:0      20
00078( P | P )  157    12    16                             4:2:0      22
00077( b | b )  155    13    16                             4:2:0      25
00080( P | P )  161    13    16                             4:2:0      26
00079( b | b )  159    14    16                             4:2:0      28
00082( P | P )  165    14    16                             4:2:0      24
00081( b | b )  163    15    16                             4:2:0      30
00086( P | P )  173    15    16                             4:2:0      23
00084( B | B )  169    16    16                             4:2:0      29
00083( b | b )  167    17    18                             4:2:0      26
00085( b | b )  171    17    18                             4:2:0      29
00090( P | P )  181    17    16                             4:2:0      23
00088( B | B )  177    18    16                             4:2:0      28
00087( b | b )  175    19    18                             4:2:0      30
00089( b | b )  179    19    18                             4:2:0      31
00092( I )      184    19    18                             4:2:0      66

comment:4 Changed 5 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.