Opened 5 years ago

Closed 5 years ago

#3381 closed defect (duplicate)

Can't open image file with non-ASCII character in file name

Reported by: Damian Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords: image2
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffmpeg.exe cannot open a file called Café.jpg (note the accented "e"), although it can open the same file if it is renamed to Cafe.jpg (no accent), and it can open a file called Café.mpg (a movie file instead of an image file).

The error is:

Café.jpg: No such file or directory

I'm using ffmpeg-20140211-git-6c12b1d-win32-static.7z from http://ffmpeg.zeranoe.com/builds/ on Windows 7 SP1 32 bit.

Full output of ffmpeg.exe -v 9 -loglevel 99 -i Café.jpg -report:

ffmpeg started on 2014-02-12 at 12:46:02
Report written to "ffmpeg-20140212-124602.log"
Command line:
ffmpeg -v 9 -loglevel 99 -i "Caf\xe9.jpg" -report
ffmpeg version N-60530-g6c12b1d Copyright (c) 2000-2014 the FFmpeg developers
  built on Feb 10 2014 22:01:44 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 63.101 / 52. 63.101
  libavcodec     55. 50.100 / 55. 50.100
  libavformat    55. 31.100 / 55. 31.100
  libavdevice    55.  8.100 / 55.  8.100
  libavfilter     4.  1.102 /  4.  1.102
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '9'.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-i' ... matched as input file with argument 'Café.jpg'.
Reading option '-report' ... matched as option 'report' (generate a report) with argument '1'.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option v (set logging level) with argument 9.
Applying option loglevel (set logging level) with argument 99.
Applying option report (generate a report) with argument 1.
Successfully parsed a group of options.
Parsing a group of options: input file Café.jpg.
Successfully parsed a group of options.
Opening an input file: Café.jpg.
[image2 @ 002dfa60] Could find no file with path 'Café.jpg' and index in the range 0-4
Café.jpg: No such file or directory

After renaming the file to remove the accent, full output of ffmpeg.exe -v 9 -loglevel 99 -i Cafe.jpg -report:

ffmpeg started on 2014-02-12 at 12:54:12
Report written to "ffmpeg-20140212-125412.log"
Command line:
ffmpeg -v 9 -loglevel 99 -i Cafe.jpg -report
ffmpeg version N-60530-g6c12b1d Copyright (c) 2000-2014 the FFmpeg developers
  built on Feb 10 2014 22:01:44 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 63.101 / 52. 63.101
  libavcodec     55. 50.100 / 55. 50.100
  libavformat    55. 31.100 / 55. 31.100
  libavdevice    55.  8.100 / 55.  8.100
  libavfilter     4.  1.102 /  4.  1.102
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Splitting the commandline.
Reading option '-v' ... matched as option 'v' (set logging level) with argument '9'.
Reading option '-loglevel' ... matched as option 'loglevel' (set logging level) with argument '99'.
Reading option '-i' ... matched as input file with argument 'Cafe.jpg'.
Reading option '-report' ... matched as option 'report' (generate a report) with argument '1'.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option v (set logging level) with argument 9.
Applying option loglevel (set logging level) with argument 99.
Applying option report (generate a report) with argument 1.
Successfully parsed a group of options.
Parsing a group of options: input file Cafe.jpg.
Successfully parsed a group of options.
Opening an input file: Cafe.jpg.
[AVIOContext @ 003a8d60] Statistics: 486060 bytes read, 0 seeks
[mjpeg @ 003a87c0] marker=d8 avail_size_in_buf=486058
[mjpeg @ 003a87c0] marker parser used 0 bytes (0 bits)
[mjpeg @ 003a87c0] marker=e0 avail_size_in_buf=486056
[mjpeg @ 003a87c0] marker parser used 16 bytes (128 bits)
[mjpeg @ 003a87c0] marker=e1 avail_size_in_buf=486038
[mjpeg @ 003a87c0] marker parser used 63 bytes (504 bits)
[mjpeg @ 003a87c0] marker=db avail_size_in_buf=485972
[mjpeg @ 003a87c0] index=0
[mjpeg @ 003a87c0] qscale[0]: 0
[mjpeg @ 003a87c0] marker parser used 67 bytes (536 bits)
[mjpeg @ 003a87c0] marker=db avail_size_in_buf=485903
[mjpeg @ 003a87c0] index=1
[mjpeg @ 003a87c0] qscale[1]: 1
[mjpeg @ 003a87c0] marker parser used 67 bytes (536 bits)
[mjpeg @ 003a87c0] marker=c0 avail_size_in_buf=485834
[mjpeg @ 003a87c0] sof0: picture: 1920x1080
[mjpeg @ 003a87c0] component 0 2:2 id: 0 quant:0
[mjpeg @ 003a87c0] component 1 1:1 id: 1 quant:1
[mjpeg @ 003a87c0] component 2 1:1 id: 2 quant:1
[mjpeg @ 003a87c0] pix fmt id 22111100
[mjpeg @ 003a87c0] marker parser used 17 bytes (136 bits)
[mjpeg @ 003a87c0] marker=c4 avail_size_in_buf=485815
[mjpeg @ 003a87c0] class=0 index=0 nb_codes=12
[mjpeg @ 003a87c0] marker parser used 31 bytes (248 bits)
[mjpeg @ 003a87c0] marker=c4 avail_size_in_buf=485782
[mjpeg @ 003a87c0] class=1 index=0 nb_codes=251
[mjpeg @ 003a87c0] marker parser used 181 bytes (1448 bits)
[mjpeg @ 003a87c0] marker=c4 avail_size_in_buf=485599
[mjpeg @ 003a87c0] class=0 index=1 nb_codes=12
[mjpeg @ 003a87c0] marker parser used 31 bytes (248 bits)
[mjpeg @ 003a87c0] marker=c4 avail_size_in_buf=485566
[mjpeg @ 003a87c0] class=1 index=1 nb_codes=251
[mjpeg @ 003a87c0] marker parser used 181 bytes (1448 bits)
[mjpeg @ 003a87c0] escaping removed 14009 bytes
[mjpeg @ 003a87c0] marker=da avail_size_in_buf=485383
[mjpeg @ 003a87c0] component: 0
[mjpeg @ 003a87c0] component: 1
[mjpeg @ 003a87c0] component: 2
[mjpeg @ 003a87c0] marker parser used 471373 bytes (3770979 bits)
[mjpeg @ 003a87c0] marker=d9 avail_size_in_buf=0
[mjpeg @ 003a87c0] decode frame unused 0 bytes
Input #0, image2, from 'Cafe.jpg':
  Duration: 00:00:00.04, start: 0.000000, bitrate: N/A
    Stream #0:0, 1, 1/25: Video: mjpeg, yuvj420p(pc), 1920x1080 [SAR 72:72 DAR 16:9], 1/25, 25 tbr, 25 tbn, 25 tbc
Successfully opened the file.
At least one output file must be specified

Attachments (1)

Café.jpg (474.7 KB) - added by Damian 5 years ago.
Image with the offending file name

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by Damian

Image with the offending file name

comment:1 Changed 5 years ago by cehoyos

  • Keywords image2 added
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of ticket #819

Note: See TracTickets for help on using tickets.