Opened 5 years ago

Closed 5 years ago

#3379 closed defect (worksforme)

HEVC decoding is not multi-threaded

Reported by: luckyknight Owned by:
Priority: normal Component: undetermined
Version: git-master Keywords: HEVC
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Not sure if this is as intended or the current state of HEVC decoding in ffmpeg, but I am only seeing a single core of my dual core CPU being used when ffmpeg is decoding a HEVC file.

This causes issues with certain files (10gb or more with 1080p resolution) due to the processing power required.

openHEVC is multi-threaded I believe.

Change History (2)

comment:1 Changed 5 years ago by luckyknight

Note that I am using ffmpeg as a library within XBMC

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.