Opened 5 years ago

Closed 5 years ago

#3377 closed defect (fixed)

qt rawvideo rgba regression

Reported by: ami_stuff Owned by:
Priority: important Component: avformat
Version: git-master Keywords: mov regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

git-9b195dd 21-Dec-2013 - ok
git-4156df5 27-Dec-2013 - bad

http://www.datafilehost.com/d/510a94ff

C:\>ffmpeg -i raw2.mov out2.avi
ffmpeg version N-60329-ge708424 Copyright (c) 2000-2014 the FFmpeg developers
  built on Feb  3 2014 22:01:02 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aa
cenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavp
ack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 63.100 / 52. 63.100
  libavcodec     55. 49.101 / 55. 49.101
  libavformat    55. 29.101 / 55. 29.101
  libavdevice    55.  7.100 / 55.  7.100
  libavfilter     4.  1.102 /  4.  1.102
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
[rawvideo @ 02ace780] Invalid pixel format.
[mov,mp4,m4a,3gp,3g2,mj2 @ 02aca680] Failed to open codec in av_find_stream_info

[rawvideo @ 02ace780] Invalid pixel format.
Input #0, mov,mp4,m4a,3gp,3g2,mj2, from 'raw2.mov':
  Metadata:
    major_brand     : qt
    minor_version   : 537199360
    compatible_brands: qt
    creation_time   : 2012-03-24 19:45:10
  Duration: 00:00:05.96, start: 0.000000, bitrate: 18435 kb/s
    Stream #0:0(eng): Video: rawvideo (raw  / 0x20776172), 189x127, 18434 kb/s,
24 fps, 24 tbr, 1000k tbn, 1000k tbc (default)
    Metadata:
      creation_time   : 2012-03-24 19:45:10
      handler_name    : Procedura obs-ugi skrˇtˇw danych Apple
[buffer @ 02bb8580] Unable to parse option value "-1" as pixel format
    Last message repeated 1 times
[buffer @ 02bb8580] Error setting option pix_fmt to value -1.
[graph 0 input from stream 0:0 @ 02acf460] Error applying options to the filter.

Error opening filters!

Attachments (1)

0003-Fix-decoding-of-32bit-rawvideo-in-mov.patch (1.3 KB) - added by cehoyos 5 years ago.

Download all attachments as: .zip

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

Regression since 691dec62

comment:2 Changed 5 years ago by cehoyos

  • Component changed from avcodec to avformat
  • Keywords mov added
  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed in 54bbe3e2
Thank you for the report!

Note: See TracTickets for help on using tickets.