Opened 5 years ago

Closed 5 years ago

#337 closed defect (worksforme)

FFmpeg's isaTTY check makes programatically parsing stderr impossible

Reported by: tommedema Owned by: michael
Priority: normal Component: ffmpeg
Version: git-master Keywords: console tty loglevel programming interaction debug progress
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


What you were trying to accomplish (e.g., "I am trying to transcode from this format to that format...")
I am programatically spawning FFmpeg, trying to parse "progress" info from stderr using the following regular expression:


An example entry:

52kB time=00:00:11.43 bitrate= 37.4kbits/s

These entries are displayed just fine when I run ffmpeg in the console (TTY).

The problem you encountered (e.g., "ffmpeg crashed" or "The output video was all green")

When I spawn a ffmpeg process programatically, ffmpeg refuces to listen to the -loglevel command because it performs a is-a-tty check and seems to not provide as much debug information when it is not a TTY (which is the case when spawning programatically and piping stderr data to certain streams).

Change History (2)

comment:1 Changed 5 years ago by michael

  • Reproduced by developer unset

Please provide enough information so this can be reproduced

comment:2 Changed 5 years ago by michael

  • Resolution set to worksforme
  • Status changed from new to closed

I cannot reproduce this, and no information about how one could reproduce this has been provided.
Feel free to reopen if you can still reproduce this problem

Note: See TracTickets for help on using tickets.