Opened 5 years ago

Closed 5 years ago

#3349 closed enhancement (invalid)

Use the output of ffprobe to feed options to ffmpeg

Reported by: burek Owned by:
Priority: wish Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I understand this feature is kinda highly idealistic, but I'll create it anyway, because if it is possible to implement even the small portion of it, that would also be great.

The idea is to use the output of ffprobe (or ffmpeg) and get the input video/audio parameters, which would be used to feed appropriate options to ffmpeg so it can encode other files in a similar fashion.

The output could be a simple command line with options that are suggested as a close match to the original file encoding options used.

Change History (2)

comment:1 in reply to: ↑ description Changed 5 years ago by saste

Replying to burek:

I understand this feature is kinda highly idealistic, but I'll create it anyway, because if it is possible to implement even the small portion of it, that would also be great.

The idea is to use the output of ffprobe (or ffmpeg) and get the input video/audio parameters, which would be used to feed appropriate options to ffmpeg so it can encode other files in a similar fashion.

"In a similiar fashion" doesn't make sense in a technical sense, since it is not clear what are the adopted similarity criteria (codecs, bitrate, timestamps, pixel formats, frame rate etc.). Since there is no absolute answer to this, since it really depends on user requirements, I see no obvious/sane way to implement such a feature.

Last edited 5 years ago by saste (previous) (diff)

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

As-is, this does not seem like a valid enhancement request.

Note: See TracTickets for help on using tickets.