Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#3305 closed enhancement (duplicate)

Add support for physical DVDs in drives (perhaps through libdvdread)

Reported by: thebombzen Owned by:
Priority: wish Component: avdevice
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
FFmpeg cannot read physical discs, especially if they're encrypted.

How to reproduce (with an encrypted DVD):

ffmpeg -i /dev/sr0

analyzes my DVD as an MP3 with:

[mp3 @ 0x12c6e60] Format mp3 detected only with low score of 1, misdetection possible!

Using

ffmpeg -f mpeg -i /dev/sr0

does not obtain the audio stream and provides an incorrect video stream for playback (because of encryption).

Proposed fix:
Add support for something along the lines of

ffmpeg -f libdvdread -i /dev/sr0

libdvdread can automatically decrypt dvds if you have libdvdcss installed, and it won't fail silently if you don't.

Change History (3)

comment:1 Changed 5 years ago by cehoyos

  • Keywords dvd libdvdread encrypted removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #3280

comment:2 Changed 5 years ago by thebombzen

This is not a duplicate of #3280 because that requests support for dvdnav packets where I am specifically requesting support for encrypted physical DVDs through libdvdread. (AFAIK you can't read from an encrypted ISO, you NEED the disc.)

comment:3 Changed 5 years ago by cehoyos

Then I suggest to test this ticket again once #3280 is implemented.

Note: See TracTickets for help on using tickets.