Opened 5 years ago

Closed 4 years ago

#326 closed defect (fixed)

ffmpeg make Circular xxxxxx/xxxx <- xxxxxxx/ dependency dropped

Reported by: yxmline Owned by:
Priority: normal Component: build system
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency drd.pe
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/endency dropped.
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mimic.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mjpeg.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mjpeg.o <- libavcodec/ dependency dropped
make: Circular libavcodec/mjpeg.o <- libavcodec/ dependency dropped
make distclean too slow

Change History (7)

comment:1 Changed 5 years ago by yxmline

ps Only the dynamic libraries at compile this information appears
Using msys + mingw + gcc-4.5.2
This information and make / make install / make distclean is abnormal slow to appear in the update to g8c0cbb0

comment:2 Changed 5 years ago by heleppkes

I'm seeing the same issue with a mingw compilation here.

comment:3 Changed 5 years ago by cehoyos

Could you explain what the issue is and how to reproduce?

comment:4 Changed 5 years ago by heleppkes

The issue is that builds take ages to complete on mingw now (even a "make distclean" takes minutes now), and loads of the errors shown by the OP are spammed during build.

I tracked it down to following commit: 5e27ec28f0aa263fc6af60ea88677e2c40631920
Reverting this one fixes it for me.

Version 0, edited 5 years ago by heleppkes (next)

comment:5 Changed 5 years ago by cehoyos

  • Component changed from undetermined to build system
  • Status changed from new to open

I do not see the messages with current git head (and ./configure && make), but every call to make has a large initial delay (especially noticeable with make distclean).

comment:6 Changed 5 years ago by yxmline

Thank you
Able to generate dynamic libraries
make / make distclean / make install is not a serious delay

comment:7 Changed 4 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed

I interpret "Thank you Able to generate dynamic libraries make / make distclean / make install is not a serious delay"

as that this bug has been fixes and is not reproduceable anymore
if not, please reopen!

Note: See TracTickets for help on using tickets.