Opened 5 years ago

Closed 5 years ago

#3258 closed defect (needs_more_info)

TS4 to MP4

Reported by: fwka01 Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Dear All, I am not very familiar with ffmpeg but tried to copy a string together from several references in order to convert a ts4 file to mp4. Unfortunately I receive following sps and pps error messages. Nevertheless, I can process the mp4 file but experience a delay of around 1 second with the audio-track compared to the video track.
I would appreciate any help to find the right string. The result should be a HD mp4 file.

Many thanks in advance, Thomas

PS. I stopped following example after a few seconds on purpose in order to reduce the clipboard text

C:\>
ffmpeg -y -i "31.12.2012 18_26_40 Udo Lindenberg_ MTV Unplugged - Live aus de
m Hotel Atlantic.TS4" -b 1550000 -bt 1792000 -ac 2 udo.mp4

ffmpeg version N-58797-g4a0d827 Copyright (c) 2000-2013 the FFmpeg developers

built on Dec 6 2013 02:21:57 with gcc 4.8.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av

isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aa
cenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavp
ack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib

libavutil 52. 56.100 / 52. 56.100
libavcodec 55. 45.100 / 55. 45.100
libavformat 55. 22.100 / 55. 22.100
libavdevice 55. 5.102 / 55. 5.102
libavfilter 3. 91.100 / 3. 91.100
libswscale 2. 5.101 / 2. 5.101
libswresample 0. 17.104 / 0. 17.104
libpostproc 52. 3.100 / 52. 3.100

[NULL @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[NULL @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 2 times

[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 1 times

[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 3 times

[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 2 times

[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 1 times

[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 1 times

[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 1 times

[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 5 times

[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS referenced
[h264 @ 02a5eb00] non-existing SPS 0 referenced in buffering period
[h264 @ 02a5eb00] non-existing PPS 0 referenced
[h264 @ 02a5eb00] decode_slice_header error
[h264 @ 02a5eb00] no frame!
[mp1 @ 02b60220] Header missing

Last message repeated 116 times

[mpegts @ 02a5aa00] decoding for stream 1 failed
[mpegts @ 02a5aa00] PES packet size mismatch

Last message repeated 4 times

[mpegts @ 02a5aa00] Could not find codec parameters for stream 1 (Audio: mp1, 0
channels, s16p): unspecified frame size
Consider increasing the value for the 'analyzeduration' and 'probesize' options
Input #0, mpegts, from '31.12.2012 18_26_40 Udo Lindenberg_ MTV Unplugged - Live

aus dem Hotel Atlantic.TS4':

Duration: 00:03:06.09, start: 45309.744689, bitrate: 13750 kb/s

Stream #0:0[0x196e]: Video: h264 (High), yuv420p(tv, bt709), 1280x720 [SAR 1

:1 DAR 16:9], 50 fps, 50 tbr, 90k tbn, 100 tbc

Stream #0:1[0x1982]: Audio: mp1, 0 channels, s16p
Stream #0:2[0x197a]: Audio: ac3, 48000 Hz, stereo, fltp, 448 kb/s
Stream #0:3[0x1979]: Audio: mp2, 48000 Hz, stereo, s16p, 192 kb/s
Stream #0:4[0x1978]: Audio: mp2, 48000 Hz, stereo, s16p, 256 kb/s
Stream #0:5[0x197b]: Audio: mp2, 48000 Hz, stereo, s16p, 192 kb/s

Please use -b:a or -b:v, -b is ambiguous
[libx264 @ 03cd0300] using SAR=1/1
[libx264 @ 03cd0300] using cpu capabilities: MMX2 SSE2Fast SSSE3 SSE4.2
[libx264 @ 03cd0300] profile High, level 3.2
[libx264 @ 03cd0300] 264 - core 140 r2377 1ca7bb9 - H.264/MPEG-4 AVC codec - Cop
yleft 2003-2013 - http://www.videolan.org/x264.html - options: cabac=1 ref=3 deb
lock=1:0:0 analyse=0x3:0x113 me=hex subme=7 psy=1 psy_rd=1.00:0.00 mixed_ref=1 m
e_range=16 chroma_me=1 trellis=1 8x8dct=1 cqm=0 deadzone=21,11 fast_pskip=1 chro
ma_qp_offset=-2 threads=6 lookahead_threads=1 sliced_threads=0 nr=0 decimate=1 i
nterlaced=0 bluray_compat=0 constrained_intra=0 bframes=3 b_pyramid=2 b_adapt=1
b_bias=0 direct=1 weightb=1 open_gop=0 weightp=2 keyint=250 keyint_min=25 scenec
ut=40 intra_refresh=0 rc_lookahead=40 rc=abr mbtree=1 bitrate=1550 ratetol=1.0 q
comp=0.60 qpmin=0 qpmax=69 qpstep=4 ip_ratio=1.40 aq=1:1.00
Output #0, mp4, to 'udo.mp4':

Metadata:

encoder : Lavf55.22.100
Stream #0:0: Video: h264 (libx264) ([33][0][0][0] / 0x0021), yuv420p, 1280x7

20 [SAR 1:1 DAR 16:9], q=-1--1, 1550 kb/s, 12800 tbn, 50 tbc

Stream #0:1: Audio: aac (libvo_aacenc) ([64][0][0][0] / 0x0040), 48000 Hz, s

tereo, s16, 128 kb/s
Stream mapping:

Stream #0:0 -> #0:0 (h264 -> libx264)
Stream #0:2 -> #0:1 (ac3 -> libvo_aacenc)

Press [q] to stop, ? for help
frame= 62 fps=0.0 q=41.0 size= 45kB time=00:00:00.79 bitrate= 466.7kbits/
frame= 89 fps= 84 q=30.0 size= 84kB time=00:00:01.24 bitrate= 554.4kbits/
frame= 107 fps= 66 q=27.0 size= 153kB time=00:00:01.58 bitrate= 790.4kbits/
frame= 124 fps= 58 q=32.0 size= 338kB time=00:00:01.88 bitrate=1468.0kbits/
frame= 146 fps= 55 q=33.0 size= 444kB time=00:00:02.35 bitrate=1543.2kbits/
frame= 166 fps= 52 q=33.0 size= 536kB time=00:00:02.84 bitrate=1542.0kbits/
frame= 186 fps= 50 q=33.0 size= 621kB time=00:00:03.16 bitrate=1605.7kbits/
frame= 207 fps= 49 q=33.0 size= 727kB time=00:00:03.63 bitrate=1637.6kbits/
frame= 215 fps= 40 q=-1.0 Lsize= 934kB time=00:00:04.26 bitrate=1795.6kbits
/s dup=51 drop=0
video:871kB audio:58kB subtitle:0 global headers:0kB muxing overhead 0.525982%
[libx264 @ 03cd0300] frame I:3 Avg QP:24.02 size: 54556
[libx264 @ 03cd0300] frame P:170 Avg QP:27.27 size: 4223
[libx264 @ 03cd0300] frame B:42 Avg QP:32.16 size: 217
[libx264 @ 03cd0300] consecutive B-frames: 73.5% 0.9% 1.4% 24.2%
[libx264 @ 03cd0300] mb I I16..4: 13.6% 72.4% 14.0%
[libx264 @ 03cd0300] mb P I16..4: 0.3% 0.8% 0.1% P16..4: 22.2% 4.0% 2.5%

0.0% 0.0% skip:70.2%

[libx264 @ 03cd0300] mb B I16..4: 0.0% 0.0% 0.0% B16..8: 7.5% 0.0% 0.0%

direct: 0.0% skip:92.5% L0:27.6% L1:72.2% BI: 0.2%

[libx264 @ 03cd0300] final ratefactor: 24.97
[libx264 @ 03cd0300] 8x8 transform intra:70.7% inter:82.1%
[libx264 @ 03cd0300] coded y,uvDC,uvAC intra: 57.9% 79.9% 43.0% inter: 4.9% 9.9%

0.7%

[libx264 @ 03cd0300] i16 v,h,dc,p: 33% 25% 7% 35%
[libx264 @ 03cd0300] i8 v,h,dc,ddl,ddr,vr,hd,vl,hu: 24% 18% 20% 5% 7% 7% 7%

6% 6%

[libx264 @ 03cd0300] i4 v,h,dc,ddl,ddr,vr,hd,vl,hu: 28% 23% 12% 5% 8% 7% 7%

5% 5%

[libx264 @ 03cd0300] i8c dc,h,v,p: 45% 24% 23% 8%
[libx264 @ 03cd0300] Weighted P-Frames: Y:0.0% UV:0.0%
[libx264 @ 03cd0300] ref P L0: 72.8% 14.6% 5.2% 7.4%
[libx264 @ 03cd0300] ref B L0: 88.5% 11.5%
[libx264 @ 03cd0300] ref B L1: 91.8% 8.2%
[libx264 @ 03cd0300] kb/s:1657.21

Change History (5)

comment:1 Changed 5 years ago by cehoyos

Please provide the input file.

comment:2 Changed 5 years ago by fwka01

Sorry, I just realized that I can supply the file only in a few days. The file is stored at my friends laptop only.
The file has a size of around 300 MB. Is the upload feasible? I can also provide a link to my cloud by then. Please advice.

comment:3 Changed 5 years ago by cehoyos

See http://ffmpeg.org/bugreports.html for upload information. There is no hard file size limit.

comment:4 follow-up: Changed 5 years ago by fwka01

Seems to be an upload file limit of 10 MB.
But I just found out that the source file is corrupt.
Therfore please close this ticket.
Thanks for your help!

comment:5 in reply to: ↑ 4 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Replying to fwka01:

Seems to be an upload file limit of 10 MB.

There is no hard file size limit!

But I just found out that the source file is corrupt.

FFmpeg is supposed to work with corrupt files as far as possible. If there is software that plays your file but FFmpeg does not work correctly, please upload and reopen this ticket!

Note: See TracTickets for help on using tickets.