Opened 6 years ago

Closed 6 years ago

#3240 closed defect (duplicate)

sws_getCachedContext() fail on very small resize to(below 8x8)

Reported by: vovach777 Owned by:
Priority: normal Component: swscale
Version: 2.1.1 Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:

function sws_getCachedContext() fail on very small resize to(below 8x8)

How to reproduce:

FF_API int ff_scale(ScaleContext ctx)
{
//1920x1080 -> BGRA 8x8
//SWS_FAST_BILINEAR => raise devide by ziro
//SWS_BILINEAR => returns - NULL;
    ctx->_sws = sws_getCachedContext(ctx->_sws, ctx->src_width,ctx->src_height,ctx->src_format,
                                                ctx->dst_width,ctx->dst_height,ctx->dst_format,
                                                SWS_FAST_BILINEAR,NULL,NULL,NULL);
    if (!ctx->_sws)
        return -1;

    return sws_scale(ctx->_sws, ctx->src_data,
                  ctx->src_linesize, 0, ctx->src_height, ctx->dst_data, ctx->dst_linesize);
}

ffmpeg version

#define FFMPEG_CONFIGURATION "--enable-cross-compile --yasmexe=yasm-1.2.0-win32.exe --disable-avdevice --disable-doc --disable-hwaccels --arch=x86 --target-os=win32 --disable-optimizations --assert-level=2 --enable-debug=3 --disable-programs --disable-w32threads --prefix='C:/ffmpeg32/dev'"

version 2.1

Change History (1)

comment:1 Changed 6 years ago by cehoyos

  • Component changed from undetermined to swscale
  • Resolution set to duplicate
  • Status changed from new to closed

Looks like a duplicate of ticket #3170, recompile with increased MAX_FILTER_SIZE as a workaround.

For future tickets:
Please always test current git head as explained on http://ffmpeg.org/bugreports.html
If you see a problem within a library (like libswscale), please test if the problem is also reproducible with ffmpeg (the application), this makes much easier to reproduce and by experience a fix much more likely.

Note: See TracTickets for help on using tickets.