Opened 6 years ago

Closed 6 years ago

#3206 closed defect (duplicate)

Subtitles are NOT burned into single frames of videos when you use the seek option "-ss" BEFORE the input

Reported by: DeadSix27 Owned by:
Priority: normal Component: avfilter
Version: git-master Keywords: seek
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

No subtitles are burned into single frame JPEG's(Thumbnails) of videos when you use the seek option "-ss" BEFORE the input file and the "ass" filter. But when you use the "-ss" option BEHIND the input it works fine.

Below I pasted both outputs, with the -ss before and after input file:

"-ss" after input
Does burn in Subtitles and takes ~2minutes:

% ffmpeg -i test.mkv -ss 00:03:25 -vf ass=subtitle.ass -c:v mjpeg -vframes 1 test.jpg
ffmpeg version N-58848-g4d18060 Copyright (c) 2000-2013 the FFmpeg developers
  built on Dec  6 2013 22:01:40 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --e
ray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidsta
bvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 56.100 / 52. 56.100
  libavcodec     55. 45.100 / 55. 45.100
  libavformat    55. 22.100 / 55. 22.100
  libavdevice    55.  5.102 / 55.  5.102
  libavfilter     3. 92.100 /  3. 92.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Input #0, matroska,webm, from 'test.mkv':
[Parsed_ass_0 @ 054ce4a0] Added subtitle file: 'subtitle.ass' (32 styles, 2538 events)
[swscaler @ 0564a9a0] deprecated pixel format used, make sure you did set range correctly
[Parsed_ass_0 @ 054ce4a0] fontconfig: cannot find font 'PT Sans', falling back to 'Meiryo UI Negreta'
[Parsed_ass_0 @ 054ce4a0] fontconfig: cannot find font 'PT Sans', falling back to 'DejaVu Sans Bold Oblique'
[Parsed_ass_0 @ 054ce4a0] fontconfig: cannot find font 'SNsanafonkakuP', falling back to 'Meiryo UI Negreta'
frame=    1 fps=0.0 q=0.0 Lsize=N/A time=00:00:00.04 bitrate=N/A
video:96kB audio:0kB subtitle:0 global headers:0kB muxing overhead -100.022271%

"-ss" before input
Does NOT burn in Subtitles and takes ~0.5seconds:

% ffmpeg -ss 00:03:25 -i test.mkv -vf ass=subtitle.ass -c:v mjpeg -vframes 1 test.jpg
ffmpeg version N-58848-g4d18060 Copyright (c) 2000-2013 the FFmpeg developers
  built on Dec  6 2013 22:01:40 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --e
ray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidsta
bvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 56.100 / 52. 56.100
  libavcodec     55. 45.100 / 55. 45.100
  libavformat    55. 22.100 / 55. 22.100
  libavdevice    55.  5.102 / 55.  5.102
  libavfilter     3. 92.100 /  3. 92.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
Input #0, matroska,webm, from 'test.mkv':
[Parsed_ass_0 @ 057e5fa0] Added subtitle file: 'subtitle.ass' (32 styles, 2538 events)
[swscaler @ 0571a0e0] deprecated pixel format used, make sure you did set range correctly
Press [q] to stop, [?] for help
frame=    1 fps=0.9 q=0.0 Lsize=N/A time=00:00:00.04 bitrate=N/A
video:87kB audio:0kB subtitle:0 global headers:0kB muxing overhead -100.024603%

Attachments (3)

big_buck_bunny_720p_h264.ass (828 bytes) - added by DeadSix27 6 years ago.
This is the subtitle file to test the bug on the big bunny video, please use "-ss 0:00:24.37" as a test, theres the only subtitle text.
frame_with_ss_after_input.jpg (120.2 KB) - added by DeadSix27 6 years ago.
As you can see, the subtitle works here, by using -ss after the input.
frame_with_ss_before_input.jpg (125.5 KB) - added by DeadSix27 6 years ago.
But when using -ss before the input, theres no subtitle burned in.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 6 years ago by DeadSix27

  • Summary changed from Subtitles are NOT burned single frames of videos when you use the seek option "-ss" BEFORE the input to Subtitles are NOT burned into single frames of videos when you use the seek option "-ss" BEFORE the input

comment:2 follow-up: Changed 6 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords libass ass filter subtitle seeking bug removed

Please provide the input samples.

comment:3 in reply to: ↑ 2 Changed 6 years ago by DeadSix27

Replying to cehoyos:

Please provide the input samples.

Can't without breaking copyright laws. I will try to produce sample video files without copyright.

Changed 6 years ago by DeadSix27

This is the subtitle file to test the bug on the big bunny video, please use "-ss 0:00:24.37" as a test, theres the only subtitle text.

comment:4 Changed 6 years ago by DeadSix27

I added the subtitle file, as video file i used the big bunny 720p h264 mov file, which can be downloaded here:
http://www.bigbuckbunny.org/index.php/download/ (its 400mb big, which is why i didnt upload it here..)

Changed 6 years ago by DeadSix27

As you can see, the subtitle works here, by using -ss after the input.

Changed 6 years ago by DeadSix27

But when using -ss before the input, theres no subtitle burned in.

comment:5 Changed 6 years ago by cehoyos

  • Component changed from undetermined to avfilter
  • Keywords seek added
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #2067

Note: See TracTickets for help on using tickets.