Opened 5 years ago

Closed 4 years ago

#3189 closed defect (needs_more_info)

video audio recording, A-V drift

Reported by: unknow Owned by:
Priority: wish Component: undetermined
Version: git-master Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello,

video/audio sync drift while doing real time recording with mp4 or mkv while with ffm it's totaly fine

ffmpeg -re -f alsa -i default -f x11grab -r 25 -s 1152x864 -i :0.0 -acodec libfaac -vcodec libx264 -preset superfast -threads 1 ~/rec.mkv # or .mp4

(the -re flags isn't needed to reproduce, in #615, starting at comment 23, i tested with other audio/video codec)

the same commande with .ffm output make the audio/video in sync

convert the .ffm back to mkv don't make the video/audio go out of sync

this isn't realy important to me since i can record in .ffm and remux in mkv or other if needed

ffmpeg version N-42597-g7f11c53 Copyright (c) 2000-2013 the FFmpeg developers
  built on Dec  1 2013 18:51:08 with gcc 4.8 (Debian 4.8.2-1)
  configuration: --enable-gpl --enable-version3 --enable-nonfree --enable-shared --enable-gnutls --enable-fontconfig --enable-libmp3lame --enable-libfreetype --enable-libfaac --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libtheora --enable-libvo-aacenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-openssl --enable-x11grab --enable-avresample
  libavutil      52. 54.100 / 52. 54.100
  libavcodec     55. 44.100 / 55. 44.100
  libavformat    55. 21.101 / 55. 21.101
  libavdevice    55.  5.100 / 55.  5.100
  libavfilter     3. 91.100 /  3. 91.100
  libavresample   1.  1.  0 /  1.  1.  0
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100

thanks for reading and maybe looking into it, i will maybe do some more testing if i have the time.

Change History (2)

comment:1 Changed 5 years ago by cehoyos

Are external libraries (libx264, libfaac) necessary to reproduce the problem or does it also happen with -vcodec mpeg4 -acodec aac -strict -2?

To make this a valid ticket, please provide your command line together with the complete, uncut console output.

comment:2 Changed 4 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Without the console output, it is impossible to determine the reason for the drift.

Note: See TracTickets for help on using tickets.