Opened 6 years ago

Closed 4 years ago

Last modified 4 years ago

#3099 closed enhancement (fixed)

support sdr2 files

Reported by: llogan Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: h264 sdr2
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description (last modified by cehoyos)

Apparently H.264 video. Probably made from "Micro DVR" devices from Seorim Technology.

$ ffmpeg -i ak000073.sdr2 
ffmpeg version N-57646-gf031531 Copyright (c) 2000-2013 the FFmpeg developers
  built on Oct 30 2013 11:53:30 with gcc 4.8.2 (GCC)
  configuration: --enable-gpl
  libavutil      52. 48.100 / 52. 48.100
  libavcodec     55. 39.100 / 55. 39.100
  libavformat    55. 19.104 / 55. 19.104
  libavdevice    55.  5.100 / 55.  5.100
  libavfilter     3. 90.100 /  3. 90.100
  libswscale      2.  5.101 /  2.  5.101
  libswresample   0. 17.104 /  0. 17.104
  libpostproc    52.  3.100 / 52.  3.100
ak000073.sdr2: Invalid data found when processing input

Sample ak000073.sdr2 (9.1M):
http://samples.ffmpeg.org/ffmpeg-bugs/trac/ticket3099

Micro D Player:
http://www.seorimtech.com/en/contents/customer/download/sdk/Mirco_D_Player_4.0.zip

The "Micro D Player" for Windows appears to be able to show at least one frame but consistently crashes for me, and it looks like it's using or contains some ffmpeg stuff:

$ strings _83E50CCB965F4FD0A291371E5629FF87 | grep enable
--disable-static --enable-shared --enable-gpl --enable-version3 --disable-w32threads --enable-runtime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib

Change History (4)

comment:1 Changed 6 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open

comment:2 Changed 6 years ago by cehoyos

  • Description modified (diff)

comment:3 Changed 4 years ago by llogan

  • Resolution set to fixed
  • Status changed from open to closed

The sample can now at least be demuxed and decoded, but I'm unsure if the result is correct (weird aspect ratio, noisy audio) due to not having a proper reference. I don't know which commits are responsible.

Note: See TracTickets for help on using tickets.