Opened 6 years ago

Closed 6 years ago

Last modified 5 years ago

#3096 closed defect (fixed)

ffmpeg 2.1 doesn't recognize -cookies option.

Reported by: hkt Owned by:
Priority: important Component: avformat
Version: git-master Keywords: http cookie regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

After I updated ffmpeg to 2.1, ffmpeg became not to recognize -cookies option.
ffmpeg 2.0.2 which I had been using until updated run correctly as I intended to.

I re-downloaded ffmpeg 2.0.2 source and built it, then ffmpeg did recognize -cookie option. So I suspect something wrong change was added to 2.1.

How to reproduce:

% ffmpeg -cookies [some cookies] -i url [and other options]
ffmpeg version 2.1 Copyright (c) 2000-2013 the FFmpeg developers
...
Unrecognized option 'cookies'.
Error splitting the argument list: Option not found

Change History (5)

comment:1 follow-up: Changed 6 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords regression added
  • Priority changed from normal to important
  • Version set to git-master

Could you confirm that the problem is also reproducible with current git head?

comment:2 in reply to: ↑ 1 Changed 6 years ago by hkt

Replying to cehoyos:

Could you confirm that the problem is also reproducible with current git head?

Confirmed. I can reproduce this problem with git head.
ffmpeg version N-57648-g4fab08c Copyright (c) 2000-2013 the FFmpeg developers

comment:3 Changed 6 years ago by cehoyos

  • Keywords http added
  • Reproduced by developer set
  • Status changed from new to open

Regression since 70106e73

comment:4 Changed 6 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed

comment:5 Changed 5 years ago by cehoyos

  • Keywords cookie added
Note: See TracTickets for help on using tickets.