Opened 3 years ago

Closed 3 years ago

#3094 closed defect (needs_more_info)

mjpeg and swscale: yuvj420p/yuv420p - pixel format problem

Reported by: Marcin Owned by:
Priority: normal Component: swscale
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Summary of the bug:
My application extracts frames from h264 UDP stream and saves them as jpg files.
Input pixel format is juv420p so mjpeg complains:
Incompatible pixel format 'yuv420p' for codec 'mjpeg', auto-selecting format 'yuvj420p'

Adding filter to convert pixel format from yuv420p to yuvj420p solved the problem, but since ffmpeg version n2.1 there is a new problem reported:
[swscaler @ 0xb12fea0] deprecated pixel format used, make sure you did set range correctly

Deprecated pixel format message is observed in custom applications which use ffmpeg libraries as well as in ffmpeg application.

How to reproduce:

% ffmpeg -i SOME_H264_STREAM output_%d.jpg
ffmpeg version: git-master, n2.1
built on: ubuntu 12.04

Change History (2)

comment:1 Changed 3 years ago by cehoyos

  • Keywords mjpeg yuv420p yuvj420p removed

I believe your original problem was fixed recently. Is the warning message what you want to report?
Please test current git head and add the ffmpeg command line (using tests/lena as input) together with complete, uncut console output to make this a valid ticket.

comment:2 Changed 3 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can add the missing information.

Note: See TracTickets for help on using tickets.