Opened 6 years ago

Closed 6 years ago

#3088 closed defect (fixed)

Bink seeking regression

Reported by: hxuanyu Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: bink regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

just play the attached video using ffplay, while playing, press 'Left' arrow to seek back, you can see that images shown has blocks.

Below is the commandline used:

$ ./ffplay.exe "C:\MediaSamples?\All\bink\v_bikb_10_yuv420p_0.bink"
ffplay version N-57448-gc78a416 Copyright (c) 2003-2013 the FFmpeg developers

built on Oct 26 2013 18:02:03 with gcc 4.8.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvidstab --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libwavpack --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 52. 47.101 / 52. 47.101
libavcodec 55. 38.101 / 55. 38.101
libavformat 55. 19.104 / 55. 19.104
libavdevice 55. 5.100 / 55. 5.100
libavfilter 3. 89.100 / 3. 89.100
libswscale 2. 5.101 / 2. 5.101
libswresample 0. 17.104 / 0. 17.104
libpostproc 52. 3.100 / 52. 3.100

Input #0, bink, from 'C:\MediaSamples?\All\bink\v_bikb_10_yuv420p_0.bink':

Duration: 00:00:06.00, start: 0.000000, bitrate: 669 kb/s

Stream #0:0: Video: binkvideo (BIKb / 0x624B4942), yuv420p, 200x116, 10 fps, 10 tbr, 10 tbn, 10 tbc

[binkvideo @ 036c4780] Reference block is out of bounds 0B f=0/0

Last message repeated 8 times

[binkvideo @ 036c4780] Reference block is out of bounds 0B f=0/0

Last message repeated 8 times

[binkvideo @ 036c4780] Reference block is out of bounds 0B f=0/0

Last message repeated 8 times

[binkvideo @ 036c4780] Reference block is out of bounds 0B f=0/0

Last message repeated 8 times

[binkvideo @ 036c4780] Reference block is out of bounds 0B f=0/0

Last message repeated 8 times

3.91 M-V: 0.010 fd= 30 aq= 0KB vq= 49KB sq= 0B f=0/

Attachments (2)

v_bikb_10_yuv420p_0.bink (490.0 KB) - added by hxuanyu 6 years ago.
screenshot.png (198.7 KB) - added by hxuanyu 6 years ago.

Download all attachments as: .zip

Change History (4)

Changed 6 years ago by hxuanyu

Changed 6 years ago by hxuanyu

comment:1 Changed 6 years ago by cehoyos

  • Keywords bink regression added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from videoframes read out after seek show blocks to Bink seeking regression
  • Version changed from unspecified to git-master

Regression since 69a6eddd / f2960097 - also reproducible with fate-suite/bink/RISE.BIK

comment:2 Changed 6 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.