Opened 4 years ago

Closed 3 years ago

#3013 closed enhancement (fixed)

Determination of brightness or light level

Reported by: kps1ny Owned by:
Priority: wish Component: avfilter
Version: git-master Keywords: histogram
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hello. It would be of great help if FFmpeg could analyze a still image (or frame) and output a number representing its overall brightness or light level.

Here's the problem I'm trying to solve:

1) A camera takes one photo every five minutes each day.

2) The image closest to noon from each day is appended to a growing continuous timelapse movie.

The problem is that those noon photos vary a lot in terms of light levels, because of clouds (or the lack of them). I'd like to be able to have FFmpeg look through all the photos from 11am to 1pm and grab the one closest to a consistent specified light level.

I can write the script to loop through potential photos, but I don't know whether or how FFmpeg can analyze and report some value on which to choose the best image from amongst the files we have.

After posting on the general FFmpeg forum for help and receiving no responses, someone suggested requesting this capability as a feature.

Thanks for your consideration,
-Ken

Change History (4)

comment:1 Changed 4 years ago by michael

  • Component changed from FFmpeg to avfilter
  • Type changed from sponsoring request to enhancement

comment:2 Changed 4 years ago by cehoyos

  • Keywords histogram added; brightness light level removed
  • Priority changed from normal to wish
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:4 Changed 3 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.