Opened 4 years ago

Closed 4 years ago

#2994 closed defect (duplicate)

mlp: deadlock with forced codec

Reported by: ami_stuff Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: deadlock
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

http://samples.mplayerhq.hu/A-codecs/caf/audio1.caf

(the last part of deadlocks found by me)

(gdb) r -acodec mlp -threads 1 -i v/audio1.caf -vn -f null -
The program being debugged has been started already.
Start it from the beginning? (y or n) y

Starting program: /media/sdb1/ffmpeg-HEAD-93439e8/ffmpeg_g -acodec mlp -threads 1 -i v/audio1.caf -vn -f null -
[Thread debugging using libthread_db enabled]
Using host libthread_db library "/lib/i386-linux-gnu/libthread_db.so.1".
ffmpeg version 2.0-93439e8 Copyright (c) 2000-2013 the FFmpeg developers
  built on Sep 18 2013 23:23:15 with gcc 4.7 (Debian 4.7.2-5)
  configuration: --disable-yasm --enable-gpl --disable-ffprobe --disable-ffserver
  libavutil      52. 44.100 / 52. 44.100
  libavcodec     55. 31.101 / 55. 31.101
  libavformat    55. 18.100 / 55. 18.100
  libavdevice    55.  3.100 / 55.  3.100
  libavfilter     3. 86.101 /  3. 86.101
  libswscale      2.  5.100 /  2.  5.100
  libswresample   0. 17.103 /  0. 17.103
  libpostproc    52.  3.100 / 52.  3.100
[mlp @ 0x91156c0] Stream parameters not seen; skipping frame.
    Last message repeated 46 times
Program received signal SIGINT, Interrupt.
0x0867890f in avcodec_get_frame_defaults (frame=0x9163e20)
    at libavcodec/utils.c:1001
1001	    memset(frame, 0, sizeof(AVFrame));
(gdb) bt
#0  0x0867890f in avcodec_get_frame_defaults (frame=0x9163e20)
    at libavcodec/utils.c:1001
#1  0x08234e67 in try_decode_frame (st=st@entry=0x9115480, 
    avpkt=avpkt@entry=0x9163da0, options=0x0) at libavformat/utils.c:2487
#2  0x0823e691 in avformat_find_stream_info (ic=0x9114e80, options=0x9115aa0)
    at libavformat/utils.c:2936
#3  0x080a66b5 in open_input_file (o=o@entry=0xbffff50c, 
    filename=<optimized out>) at ffmpeg_opt.c:809
#4  0x080a4ed7 in open_files (inout=inout@entry=0x88e725b "input", 
    open_file=open_file@entry=0x80a62d0 <open_input_file>, 
    l=<error reading variable: Unhandled dwarf expression opcode 0xfa>, 
    l=<error reading variable: Unhandled dwarf expression opcode 0xfa>)
    at ffmpeg_opt.c:2494
#5  0x080ad0e9 in ffmpeg_parse_options (argc=argc@entry=11, 
    argv=argv@entry=0xbffff994) at ffmpeg_opt.c:2531
#6  0x080a25da in main (argc=11, argv=0xbffff994) at ffmpeg.c:3393
(gdb) 

Change History (2)

comment:1 Changed 4 years ago by cehoyos

  • Keywords deadlock added
  • Priority changed from normal to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:2 Changed 4 years ago by michael

  • Resolution set to duplicate
  • Status changed from open to closed

Duplicate of Ticket2986 i think (cant reproduce it anymore)

Note: See TracTickets for help on using tickets.