Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#2963 closed enhancement (fixed)

Enable trac tickets tag cloud

Reported by: saste Owned by:
Priority: wish Component: trac
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I believe there are already available plugins for trac, for example:
http://trac-hacks.org/wiki/TagsPlugin/TagCloud

Allowing a tag cloud could be useful to navigate / inspect the tickets.

Change History (7)

comment:1 follow-up: Changed 6 years ago by beastd

Hi,

I like the idea of showing a tag cloud. It is hard to measure any benifits, but
it should aid exploration of the content contained in our trac.

Do you wish the tag cloud for the wiki or for the tickets?

The plugin you linked to seems to support both. As far as I understood it adds
the possibility to tag wiki pages and uses the keywords from the tickets. So
I guess the tag cloud will be for combined generated from wiki tags and ticket
keywords.

At least using keywords as tags should work out well for our tickets base.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 6 years ago by saste

Replying to beastd:

Hi,

I like the idea of showing a tag cloud. It is hard to measure any benifits, but
it should aid exploration of the content contained in our trac.

Do you wish the tag cloud for the wiki or for the tickets?

I believe they should stay separate, since they have different kind of users (developers navigating tickets vs. users navigating docs). As I'm a developer, I'm mostly interested in ticket tags.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 6 years ago by beastd

  • Resolution set to fixed
  • Status changed from new to closed

Replying to saste:

Replying to beastd:

Hi,

I like the idea of showing a tag cloud. It is hard to measure any benifits, but
it should aid exploration of the content contained in our trac.

Do you wish the tag cloud for the wiki or for the tickets?

I believe they should stay separate, since they have different kind of users (developers navigating tickets vs. users navigating docs). As I'm a developer, I'm mostly interested in ticket tags.

OK. Tags are now available. See the Tags link in the Trac main navigation bar.

For now it only works for tickets and uses the words in the keywords field. I modified our installation to treat the tags case in-sensitive, so e.g. avi and AVI is merged into one tag.

Tagging for Wiki pages could also be allowed if it is wanted.

Please re-open if you have wishes for further adjustments.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 6 years ago by cehoyos

Replying to beastd:

I modified our installation to treat the tags case in-sensitive, so e.g. avi and AVI is merged into one tag.

This is correct (it should not be changed).

comment:5 in reply to: ↑ 4 ; follow-up: Changed 6 years ago by beastd

Replying to cehoyos:

Replying to beastd:

I modified our installation to treat the tags case in-sensitive, so e.g. avi and AVI is merged into one tag.

This is correct (it should not be changed).

Only to be sure: Since you did not re-open I assume you are fine with the current behaviour.

I wrote it a bit ambiguous above. But I meant to say that the tags, which are the keywords of the tickets in our case, do not get changed in any way. Tags with differing case are just treated the same when listed or displayed in a tag cloud.

One caveat is that you need to use lower case in the tag search. I could look into fixing that too if is wanted.

comment:6 in reply to: ↑ 5 ; follow-up: Changed 6 years ago by cehoyos

Replying to beastd:

Replying to cehoyos:

Replying to beastd:

I modified our installation to treat the tags case in-sensitive, so e.g. avi and AVI is merged into one tag.

This is correct (it should not be changed).

Only to be sure: Since you did not re-open I assume you are fine with the current behaviour.

I did not test myself but if the current behaviour is that "MPEGTS" and "mpegts" are equivalent then it is correct and intended imo.

I wrote it a bit ambiguous above. But I meant to say that the tags, which are the keywords of the tickets in our case, do not get changed in any way. Tags with differing case are just treated the same when listed or displayed in a tag cloud.

Good!

One caveat is that you need to use lower case in the tag search. I could look into fixing that too if is wanted.

I seem to misunderstand this because searching for a tag with wrong (upper-) case seems to work fine.

comment:7 in reply to: ↑ 6 Changed 6 years ago by beastd

Replying to cehoyos:

Replying to beastd:

Only to be sure: Since you did not re-open I assume you are fine with the current behaviour.

I did not test myself but if the current behaviour is that "MPEGTS" and "mpegts" are equivalent then it is correct and intended imo.

Yes.

I wrote it a bit ambiguous above. But I meant to say that the tags, which are the keywords of the tickets in our case, do not get changed in any way. Tags with differing case are just treated the same when listed or displayed in a tag cloud.

Good!

One caveat is that you need to use lower case in the tag search. I could look into fixing that too if is wanted.

I seem to misunderstand this because searching for a tag with wrong (upper-) case seems to work fine.

Yes and no. If you search via a report/query against the ticket base it works all the same as before. The caveat only applies when searching via tags plugin e.g. here

https://trac.ffmpeg.org/tags

You need to filter exactly for mpegts as MPEGTS or even mpegt would not work, but as all tags are displayed in lowercase I think there is not much urge to use mixed or uppercase in that context.

Note: See TracTickets for help on using tickets.