Opened 5 years ago

Closed 5 years ago

Last modified 3 years ago

#292 closed defect (fixed)

ffplay -f video4linux2 regression

Reported by: cehoyos Owned by:
Priority: normal Component: avdevice
Version: git-master Keywords: ffplay regression v4l2
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

ffplay -f video4linux2 /dev/video0 does not work any more since r25159, 70f77361d8c339d516e3c4d1c4ab2bf9096d7cc6:
Author: José Miguel Gonçalves <jose.goncalves@inov.pt>
Date: Thu Sep 23 09:16:05 2010 +0000

Allow to set the frame rate in v4l2 devices
Patch by José Miguel Gonçalves (jose DOT goncalves AT inov DOT pt)

$ ffplay -f video4linux2 /dev/video0
FFplay version git-6ac6e3d, Copyright (c) 2003-2010 the FFmpeg developers
  built on Jun 21 2011 01:05:14 with gcc 4.5.3
  configuration: --cc=/usr/local/gcc-4.5.3/bin/gcc --disable-encoders --disable-muxers
  libavutil     50.27. 0 / 50.27. 0
  libavcore      0. 9. 0 /  0. 9. 0
  libavcodec    52.89. 0 / 52.89. 0
  libavformat   52.78. 5 / 52.78. 5
  libavdevice   52. 2. 2 / 52. 2. 2
  libavfilter    1.39. 0 /  1.39. 0
  libswscale     0.11. 0 /  0.11. 0
[video4linux2 @ 0x103e6d0] Estimating duration from bitrate, this may be inaccurate
Input #0, video4linux2, from '/dev/video0':
  Duration: N/A, start: 1308611201.235607, bitrate: 132710 kb/s
    Stream #0.0: Video: rawvideo, yuv420p, 768x576, 132710 kb/s, 25 tbr, 1000k tbn, 25 tbc
1308611201.62 A-V:  0.000 s:0.2 aq=    0KB vq=    0KB sq=    0B f=0/9
$ ffplay -f video4linux2 /dev/video0
FFplay version git-70f7736, Copyright (c) 2003-2010 the FFmpeg developers
  built on Jun 21 2011 01:07:25 with gcc 4.5.3
  configuration: --cc=/usr/local/gcc-4.5.3/bin/gcc --disable-encoders --disable-muxers
  libavutil     50.27. 0 / 50.27. 0
  libavcore      0. 9. 0 /  0. 9. 0
  libavcodec    52.89. 0 / 52.89. 0
  libavformat   52.78. 5 / 52.78. 5
  libavdevice   52. 2. 2 / 52. 2. 2
  libavfilter    1.39. 0 /  1.39. 0
  libswscale     0.11. 0 /  0.11. 0
[video4linux2 @ 0x103e6d0] ioctl set time per frame(1/25) failed
/dev/video0: Input/output error

Change History (4)

comment:1 Changed 5 years ago by saste

AFAIK the patch was fine and I used v4l2 so many times with no problem since then so I cannot reproduce it here. Please debug it, it should be pretty easy to spot why you get that error.

comment:2 Changed 5 years ago by saste

  • Analyzed by developer set
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in:

commit b6bde8c7702f6e6a485594fb5831e5bc04b2e763
Author: Anton Khirnov <anton@khirnov.net>
Date:   Thu Jun 9 10:58:23 2011 +0200

    ffplay: use new avformat_open_* API.

It's also possible to change the framerate using the private option -framerate.

comment:3 Changed 5 years ago by cehoyos

  • Keywords v4l added

comment:4 Changed 3 years ago by cehoyos

  • Keywords v4l2 added; v4l removed
Note: See TracTickets for help on using tickets.