Opened 6 years ago

Closed 6 years ago

#2904 closed defect (fixed)

ffplay: png apic doesn't display anymore

Reported by: ami_stuff Owned by: cus
Priority: important Component: ffplay
Version: git-master Keywords: png regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

http://www.datafilehost.com/d/1f37c74d

C:\>ffplay -vst 1 multiple_apics.mp3
ffplay version N-55753-g88909be Copyright (c) 2003-2013 the FFmpeg developers
  built on Aug 24 2013 21:40:51 with gcc 4.7.3 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-
amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --
enable-libxvid --enable-zlib
  libavutil      52. 42.100 / 52. 42.100
  libavcodec     55. 29.100 / 55. 29.100
  libavformat    55. 14.102 / 55. 14.102
  libavdevice    55.  3.100 / 55.  3.100
  libavfilter     3. 82.102 /  3. 82.102
  libswscale      2.  5.100 /  2.  5.100
  libswresample   0. 17.103 /  0. 17.103
  libpostproc    52.  3.100 / 52.  3.100
[mp3 @ 02ac50c0] Format mp3 detected only with low score of 24, misdetection pos
sible!
Input #0, mp3, from 'multiple_apics.mp3':sq=    0B f=0/0
  Metadata:
    title           : title
    album           : album
    artist          : artist
    encoder         : Lavf54.6.101
    genre           : Acid Punk
    track           : 1
    date            : 1999
  Duration: 00:00:10.06, start: 0.000000, bitrate: 2117 kb/s
    Stream #0:0: Audio: mp3, 44100 Hz, stereo, s16p, 128 kb/s
    Stream #0:1: Video: png, rgb24, 640x480, 90k tbr, 90k tbn, 90k tbc
    Metadata:
      title           : studio logo
      comment         : Publisher/Studio logotype
    Stream #0:2: Video: mjpeg, yuvj420p, 320x240, 90k tbr, 90k tbn, 90k tbc
    Metadata:
      title           : other
      comment         : Other
    Stream #0:3: Video: png, rgb24, 1024x768, 90k tbr, 90k tbn, 90k tbc
    Metadata:
      title           : illustration
      comment         : Illustration
    Stream #0:4: Video: mjpeg, yuvj420p, 1024x768, 90k tbr, 90k tbn, 90k tbc
    Metadata:
      title           : cover
      comment         : Cover (front)
   0.71 A-V:    nan fd=   0 aq=    2KB vq=    0KB sq=    0B f=0/0

Change History (5)

comment:1 Changed 6 years ago by ami_stuff

works ok with -threads 1

comment:2 Changed 6 years ago by richardpl

  • Component changed from undetermined to FFplay
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:3 Changed 6 years ago by cus

  • Analyzed by developer set
  • Owner set to cus
  • Reproduced by developer set

comment:4 Changed 6 years ago by cehoyos

  • Analyzed by developer unset
  • Keywords png regression added
  • Priority changed from normal to important

Regression since 6e64323.

comment:5 Changed 6 years ago by cus

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.