Opened 3 years ago

Closed 2 years ago

#2902 closed defect (invalid)

ICL13 compiler configuration failure

Reported by: janos666 Owned by:
Priority: normal Component: build system
Version: git-master Keywords: icl
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no


Summary of the bug: ICL13 compiler configuration fail
How to reproduce: Do everything as written here:

WARNING: pkg-config not found, library detection may fail.
mktemp -u XXXXXX
WARNING: Unknown C compiler c99wrap -noconv icl, unable to select optimal CFLAGS
check_ld cc
BEGIN /tmp/ffconf.WmSCWKfn.c
    1	int main(void){ return 0; }
END /tmp/ffconf.WmSCWKfn.c
c99wrap -noconv icl -c -o /tmp/ffconf.CFgEVHFy.o /tmp/ffconf.WmSCWKfn.c
C compiler test failed.

I installed msys with the latest mingw-get win32 installer and I made sure to select pkginfo after I saw this error in the log but it didn't help. (This package was unavailable but I filed a bug report and it is available now. I have it installed now, even though the mingw-get package maintainer suggested that I should need this for compiling anything like ffmpeg, so this can be my misunderstanding. But the configuration fails regardless...)

ICL13 is properly installed and it seems to work correctly (I already compiled some other source code from the command line and the programs work on my PC.)

I tried both intel64 and ia32 target configurations.

Attachments (1)

config.log (116.7 KB) - added by janos666 3 years ago.
config log

Download all attachments as: .zip

Change History (9)

Changed 3 years ago by janos666

config log

comment:1 Changed 3 years ago by janos666

  • Summary changed from ICL13 compiler configuration fail to ICL13 compiler configuration failure

comment:2 Changed 3 years ago by janos666

Sorry, I made a mistake. I wrote: "I should need this" but I meant: "I should NOT need this".

comment:3 Changed 3 years ago by cehoyos

  • Keywords icl added; ICL13 removed

Please create a file test.c containing int main(void){ return 0; } run both c99wrap -noconv icl and c99wrap -noconv icl -c -o test.o test.c and post the output here.

comment:4 Changed 3 years ago by janos666

There is no output at all. Strange. c99conv has an output when I run it without parameters (c99conv.exe <in> <out>) but c99wrap remains silent with or without parameters.

comment:5 Changed 3 years ago by cehoyos

Our icl tests are online again (they were stalled for three weeks due to hardware move) and appear to work fine:

comment:6 Changed 3 years ago by nikolaynnov

I have the same bug with c99wrap 1.0.1. It just does nothing with -noconv option. Upgrade to c99-to-88 v1.0.2 resolved issue with c99wrap. Please note what c99-to-88 1.0.2 contains another bug in makedef tool(

comment:7 Changed 3 years ago by cehoyos

Can somebody confirm that this problem is not reproducible with current c99-to-c89 from ? (It was apparently fixed one day after this ticket was created...)

comment:8 Changed 2 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

I believe this bug in c99-to-c89 was fixed in August 2013.

Note: See TracTickets for help on using tickets.