Opened 3 years ago

Closed 3 years ago

#2878 closed defect (duplicate)

Non-Existing PPS when converting AVI to MPG

Reported by: GACS_Support Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I have written an application that takes several AVI files, converts them to MPG, concatenates them together and then converts them to MP4. The AVI files are being created as recordings from a Foscam 9128.

The process creates the MPG files and are playable in VLC. However, the first frame is not correct. It is very distorted. The AVI file does not appear to have the same issue.

I am running this on a Windows 7 Professional system. I've included the output which repeats the Non-Existing PPS error over and over. Any help would be appreciated. Thanks.

C:\Program Files\ffmpeg\bin>ffmpeg -i sample.avi -y -qscale 0 sample.mpg
ffmpeg version N-52523-g0fb64da Copyright (c) 2000-2013 the FFmpeg developers

built on Apr 28 2013 00:01:23 with gcc 4.7.3 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 52. 27.101 / 52. 27.101
libavcodec 55. 6.100 / 55. 6.100
libavformat 55. 3.100 / 55. 3.100
libavdevice 55. 0.100 / 55. 0.100
libavfilter 3. 61.100 / 3. 61.100
libswscale 2. 2.100 / 2. 2.100
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 3.100 / 52. 3.100

[avi @ 024d1a40] non-interleaved AVI
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[h264 @ 02619820] non-existing PPS referenced
[h264 @ 02619820] non-existing PPS 0 referenced
[h264 @ 02619820] decode_slice_header error
[h264 @ 02619820] no frame!
[avi @ 024d1a40] max_analyze_duration 5000000 reached at 5000000 microseconds
Guessed Channel Layout for Input Stream #0.1 : mono
Input #0, avi, from 'sample.avi':

Duration: 00:01:31.28, start: 0.000000, bitrate: 364 kb/s

Stream #0:0: Video: h264 (Constrained Baseline) (H264 / 0x34363248), yuv420p, 1280x720, 21.17 fps, 25 tbr, 25 tbn, 50 tbc
Stream #0:1: Audio: pcm_s16le ([1][0][0][0] / 0x0001), 8000 Hz, mono, s16, 128 kb/s

Please use -q:a or -q:v, -qscale is ambiguous
[mpeg @ 041590a0] VBV buffer size not set, muxing may fail
Output #0, mpeg, to 'sample.mpg':

Metadata:

encoder : Lavf55.3.100
Stream #0:0: Video: mpeg1video, yuv420p, 1280x720, q=2-31, 200 kb/s, 90k tbn, 25 tbc
Stream #0:1: Audio: mp2, 16000 Hz, mono, s16, 128 kb/s

Stream mapping:

Stream #0:0 -> #0:0 (h264 -> mpeg1video)
Stream #0:1 -> #0:1 (pcm_s16le -> mp2)

Press [q] to stop, ? for help
[h264 @ 025195c0] Missing reference picture, default is 0
[h264 @ 025195c0] decode_slice_header error
frame= 2282 fps=144 q=0.0 Lsize= 24352kB time=00:01:31.24 bitrate=2186.4kbits/s dup=12 drop=0
video:24224kB audio:0kB subtitle:0 global headers:0kB muxing overhead 0.527607%

Change History (1)

comment:1 Changed 3 years ago by llogan

  • Component changed from FFmpeg to undetermined
  • Keywords non-existing pps avi mpg removed
  • Priority changed from important to normal
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #2879.

Note: See TracTickets for help on using tickets.