Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2791 closed defect (needs_more_info)

ffmpeg-master fails @ "non-existing PPS referenced"; ffmpeg-release/0.11 OK with same input

Reported by: kml2 Owned by:
Priority: important Component: undetermined
Version: git-master Keywords: regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I'm working on building ffmpeg from git sources on linux/64.

Currently, a build of master fails to play a video; a build of release -- same rev, config, same machine, same input -- works fine.

This only happens on some linux/64 machines I build the new ffmpeg-master on -- not all (They're all/always linux/64, with NVidia video). So there's some sort of ENV dependency. But the built-from-src *release* version definitely works -- both standalone AND as an external ffmpeg to XBMC. the -master branch does not.

Here's what I'm doing

cd /usr/local/src/ffmpeg

git log | head -n 3
	commit a80e622924c89df69fb1c225ba432fe12fe6648e
	Author: Michael Niedermayer <michaelni@gmx.at>
	Date:   Sun Jul 14 19:13:46 2013 +0200

./configure ...
make
make install
ldconfig
/usr/local/bin/ffmpeg -i MyMovie.mkv ...
	ffmpeg version N-54771-ga80e622 Copyright (c) 2000-2013 the FFmpeg developers
	...
	[h264 @ 0x1f09700] non-existing PPS referenced
	[h264 @ 0x1f09700] non-existing PPS 9 referenced
	[h264 @ 0x1f09700] decode_slice_header error
	[h264 @ 0x1f09700] no frame!
	[h264 @ 0x1f09700] first_mb_in_slice overflow
	[h264 @ 0x1f09700] decode_slice_header error
	[h264 @ 0x1f09700] number of reference frames (0+17) exceeds max (16; probably corrupt input), discarding one
	[h264 @ 0x1f09700] non-existing PPS referenced
	[h264 @ 0x1f09700] slice type too large (32) at 0 0
	[h264 @ 0x1f09700] decode_slice_header error
	[h264 @ 0x1f09700] no frame!
	[h264 @ 0x1f09700] non-existing PPS referenced
	[h264 @ 0x1f09700] slice type too large (11) at 0 0
	[h264 @ 0x1f09700] decode_slice_header error
	[h264 @ 0x1f09700] no frame!
	[h264 @ 0x1f09700] non-existing PPS referenced
	[h264 @ 0x1f09700] non-existing PPS 19 referenced
	[h264 @ 0x1f09700] decode_slice_header error
	...

make clean
git reset --hard
git checkout -b Release011 remotes/origin/release/0.11
./configure ...
make
make install
ldconfig

/usr/local/bin/ffmpeg -i MyMovie.mkv ...
	ffmpeg version 0.11.3 Copyright (c) 2000-2013 the FFmpeg developers
	...
	Input #0, matroska,webm, from 'MyMovie.mkv':
	  Duration: 02:03:48.22, start: 0.000000, bitrate: 1677 kb/s
	    Chapter #0.0: start 0.000000, end 542.975754
	    Metadata:
	      title           : Chapter 1
	...

Cutting out a small segment

	ffmpeg -ss 0 -t 2 -i  MyMovie.mkv -vcodec copy -acodec copy MySegment.mkv

back to -master branch, verifying that I can reproduce this with MySegment?.mkv,

	/usr/local/bin/ffmpeg -i MySegment.mkv ...
		ffmpeg version N-54771-ga80e622 Copyright (c) 2000-2013 the FFmpeg developers
		...
		[h264 @ 0x19e3e80] non-existing PPS referenced
		[h264 @ 0x19e3e80] non-existing PPS 9 referenced
		[h264 @ 0x19e3e80] decode_slice_header error
		[h264 @ 0x19e3e80] no frame!
		[h264 @ 0x19e3e80] first_mb_in_slice overflow
		[h264 @ 0x19e3e80] decode_slice_header error
		[h264 @ 0x19e3e80] number of reference frames (0+17) exceeds max (16; probably corrupt input), discarding one
		[h264 @ 0x19e3e80] non-existing PPS referenced
		[h264 @ 0x19e3e80] slice type too large (32) at 0 0
		[h264 @ 0x19e3e80] decode_slice_header error
		[h264 @ 0x19e3e80] no frame!

I'm attaching MySegment?.mkv

Attachments (1)

MySegment.mkv (1.1 MB) - added by kml2 5 years ago.
a short clip of videao that demonstrates the issue

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by kml2

a short clip of videao that demonstrates the issue

comment:1 Changed 5 years ago by cehoyos

Please provide your failing command line together with the complete, uncut console output to make this a valid ticket.

comment:2 Changed 5 years ago by MarkZV

Are you using gcc 4.2.x? If so then this may be a duplicate of #1464; try a newer version of gcc.

comment:3 Changed 5 years ago by kml2

no. i'm using:
gcc version 4.8.1 20130711 [gcc-4_8-branch revision 200903]

comment:4 Changed 5 years ago by cehoyos

  • Resolution set to needs_more_info
  • Status changed from new to closed

Please reopen this ticket if you can provide a failing command line together with the complete, uncut console output.

comment:5 Changed 5 years ago by cehoyos

  • Keywords regression added
  • Priority changed from normal to important
Note: See TracTickets for help on using tickets.