Opened 5 years ago

Closed 5 years ago

#2754 closed defect (invalid)

ffmpeg exist with muxing overhead after 6-8 hours of hls transcoding from rtmp stream

Reported by: vkroutik Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Try to run this on a latest windows build:

"C:
Dev
Tools2
ffmpeg
ffmpeg.exe" -report -i rtmp://80.232.172.37/rtplive/vlc.sdp -c:v copy -c:a copy -bsf h264_mp4toannexb -bsf:a aac_adtstoasc -hls_time 10 -hls_list_size 6 -hls_wrap 60 -start_number 1 -y "C:
Dev
Tools2
Test2
stream.m3u8"

It will run for 5-6 hours and then exists with muxing overhead message:
video:659722kB audio:130577kB subtitle:0 global headers:0kB muxing overhead -100.000003%
0 frames successfully decoded, 0 decoding errors

You can find log result here:
http://www1.datafilehost.com/d/d6643879

Attachments (1)

ffmpeg-20130709-090147.log (149.0 KB) - added by vkroutik 5 years ago.
Log file where it shows command line and error

Download all attachments as: .zip

Change History (17)

comment:1 Changed 5 years ago by cehoyos

Is this problem only reproducible with network input or also with file (or test-filter) input?

Is network output required to reproduce the problem of does it also fail for file output?

comment:2 follow-up: Changed 5 years ago by vkroutik

We observe the issue with a number of rtmp streams as an input. We do not have a file which would stream for 6-8 hours!

We tested it with HLS only. Will run with file output.

comment:3 in reply to: ↑ 2 Changed 5 years ago by cehoyos

Replying to vkroutik:

We observe the issue with a number of rtmp streams as an input. We do not have a file which would stream for 6-8 hours!

You can use -f lavfi -i testsrc both to test and to produce (long) samples.

comment:4 follow-up: Changed 5 years ago by vkroutik

We run the same command, but outputing to file and after 24 hours got no errors or maxing issues.

One can conclude is issue with hls parser/streamer.

Please advise if someone can fix it?

comment:5 in reply to: ↑ 4 Changed 5 years ago by cehoyos

Replying to vkroutik:

We run the same command, but outputing to file and after 24 hours got no errors or maxing issues.

Is network input needed?

comment:6 Changed 5 years ago by vkroutik

No,

Recording failing stream to file and streaming from the file produced the same outcome => muxing overhead.

Hope it helps?

comment:7 Changed 5 years ago by cehoyos

If ffmpeg -f lavfi -i testsrc allows to reproduce the problem, please provide a command line using it (together with the complete, uncut console output) that allows a developer to reproduce.
If -vcodec copy is required, please provide the two necessary command lines.

comment:8 Changed 5 years ago by vkroutik

sorry, i tried to use this command

C:\Dev\Tools2\ffmpeg\ffmpeg.exe -f lavfi -i "rtmp://80.232.172.37/rtplive/vlc.sdp" -c:v copy -c:a copy -bsf h264_mp4toannexb -bsf:a aac_adtstoasc -hls_time 10 -hls_list_size 6 -hls_wrap 60 -start_number 1 -y "C:\Dev\Tools2\Test2\stream.m3u8"

but keep getting error with command line, please advise what is correct format

comment:9 Changed 5 years ago by cehoyos

Does ffmpeg -f lavfi -i testsrc not work?

comment:10 Changed 5 years ago by vkroutik

Sorry, I am getting Invalid argument error, see details:

ffmpeg started on 2013-07-08 at 17:31:30
Report written to "ffmpeg-20130708-173130.log"
Command line:
"C:
Dev
Tools2
ffmpeg
ffmpeg.exe" -report -f lavfi -i rtmp://80.232.172.37/rtplive/vlc.sdp -c:v copy -c:a copy -bsf h264_mp4toannexb -bsf:a aac_adtstoasc -hls_time 10 -hls_list_size 6 -hls_wrap 60 -start_number 1 -y "C:
Dev
Tools2
Test2
stream.m3u8"
ffmpeg version N-54094-gca2818b Copyright (c) 2000-2013 the FFmpeg developers

built on Jun 18 2013 03:44:52 with gcc 4.7.3 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 52. 37.101 / 52. 37.101
libavcodec 55. 16.100 / 55. 16.100
libavformat 55. 9.100 / 55. 9.100
libavdevice 55. 2.100 / 55. 2.100
libavfilter 3. 77.101 / 3. 77.101
libswscale 2. 3.100 / 2. 3.100
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 3.100 / 52. 3.100

Splitting the commandline.
Reading option '-report' ... matched as option 'report' (generate a report) with argument '1'.
Reading option '-f' ... matched as option 'f' (force format) with argument 'lavfi'.
Reading option '-i' ... matched as input file with argument 'rtmp://80.232.172.37/rtplive/vlc.sdp'.
Reading option '-c:v' ... matched as option 'c' (codec name) with argument 'copy'.
Reading option '-c:a' ... matched as option 'c' (codec name) with argument 'copy'.
Reading option '-bsf' ... matched as option 'bsf' (A comma-separated list of bitstream filters) with argument 'h264_mp4toannexb'.
Reading option '-bsf:a' ... matched as option 'bsf' (A comma-separated list of bitstream filters) with argument 'aac_adtstoasc'.
Reading option '-hls_time' ... matched as AVOption 'hls_time' with argument '10'.
Reading option '-hls_list_size' ... matched as AVOption 'hls_list_size' with argument '6'.
Reading option '-hls_wrap' ... matched as AVOption 'hls_wrap' with argument '60'.
Reading option '-start_number' ... matched as AVOption 'start_number' with argument '1'.
Reading option '-y' ... matched as option 'y' (overwrite output files) with argument '1'.
Reading option 'C:\Dev\Tools2\Test2\stream.m3u8' ... matched as output file.
Finished splitting the commandline.
Parsing a group of options: global .
Applying option report (generate a report) with argument 1.
Applying option y (overwrite output files) with argument 1.
Successfully parsed a group of options.
Parsing a group of options: input file rtmp://80.232.172.37/rtplive/vlc.sdp.
Applying option f (force format) with argument lavfi.
Successfully parsed a group of options.
Opening an input file: rtmp://80.232.172.37/rtplive/vlc.sdp.
[lavfi @ 000000000036b440] No such filter: 'rtmp://80.232.172.37/rtplive/vlc.sdp'
rtmp://80.232.172.37/rtplive/vlc.sdp: Invalid argument

comment:11 Changed 5 years ago by cehoyos

Does ffmpeg -f lavfi -i testsrc not work?

You explained above that network input is not needed to reproduce the original problem, I am trying to find a (very simply) command line that allows (both of us) to produce a testfile that allows to reproduce the problem.
If you don't want to use testsrc, maybe you have a better suggestion (that does not include recording several hours of a network stream)?

Changed 5 years ago by vkroutik

Log file where it shows command line and error

comment:12 Changed 5 years ago by vkroutik

I have run with ffmpeg -f lavfi -i testsrc and see the same error.
I am attaching output file

video:24684kB audio:0kB subtitle:0 global headers:0kB muxing overhead -100.000087%

here is a full command

"C:
Dev
Tools2
ffmpeg
ffmpeg.exe" -re -t 1000 -report -f lavfi -i testsrc -hls_time 10 -hls_list_size 6 -hls_wrap 60 -start_number 1 -y "C:
Dev
Tools2
Test2
stream.m3u8"

comment:13 Changed 5 years ago by cehoyos

Sorry if I missed it but could you explain again what the problem is with the command line you (just) posted? I don't see an error in the output (but I may have simply missed it).

comment:14 Changed 5 years ago by vkroutik

Sure, it exists with invalid muxing overhead of -100.000087%

see log attached

comment:15 Changed 5 years ago by vkroutik

I suggest to close this, as issue is with input which gets interupted...

comment:16 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.