Opened 6 years ago

Closed 5 years ago

#2650 closed enhancement (invalid)

Silence max_analyze_duration warning

Reported by: gjdfgh Owned by:
Priority: normal Component: avformat
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

We all know this warning:

max_analyze_duration 5000000 reached at 5005000 microseconds

and it's completely useless, except maybe in very special circumstances.

The log level should be changed so that the message is visible in verbose mode only. Currently it's a warning:

av_log(ic, AV_LOG_WARNING, "max_analyze_duration %d reached at %"PRId64" microseconds\n", ic->max_analyze_duration, t);

Since there is nothing wrong with a file that causes this "warning" to be printed, it really should be AV_LOG_VERBOSE instead.

Change History (2)

comment:1 Changed 6 years ago by cehoyos

Please send a patch to ffmpeg-devel to allow discussing your suggestion.

If that is impossible please point to a sample and provide the command line together with the complete, uncut console output.

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to invalid
  • Status changed from new to closed

I don't think this is the right place to discuss patches.

Note: See TracTickets for help on using tickets.