Opened 4 years ago

Closed 4 years ago

#2638 closed defect (fixed)

unrecognised tta file with id3v2 tags at begining

Reported by: cyril Owned by:
Priority: important Component: avformat
Version: git-master Keywords: id3 tta regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
True Audio format supports metadata as being ID3v1, ID3v2 or APEv2.
But ffprobe doesn't detect any id3v2 metadata on the following file: http://towerofbabel.free.fr/test/music.id3.tta while mp3tag v2.55a can see that a cover art is embedded as id3v2.3.

How to reproduce:

% ffprobe.exe music.id3.tta
ffprobe version N-53758-g5711e4f Copyright (c) 2007-2013 the FFmpeg developers
  built on Jun  2 2013 02:33:52 with gcc 4.7.3 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-iconv --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetyp
e --enable-libgsm --enable-libilbc --enable-libmodplug --enable-libmp3lame --ena
ble-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-l
ibopus --enable-librtmp --enable-libschroedinger --enable-libsoxr --enable-libsp
eex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-
amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --
enable-libxvid --enable-zlib
  libavutil      52. 34.100 / 52. 34.100
  libavcodec     55. 13.100 / 55. 13.100
  libavformat    55.  8.102 / 55.  8.102
  libavdevice    55.  2.100 / 55.  2.100
  libavfilter     3. 74.101 /  3. 74.101
  libswscale      2.  3.100 /  2.  3.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  3.100 / 52.  3.100
[tta @ 00000000026cf6c0] Format tta detected only with low score of 24, misdetec
tion possible!
Input #0, tta, from 'music.id3.tta':
  Duration: 00:23:57.77, start: 0.000000, bitrate: 1048 kb/s
    Stream #0:0: Audio: tta, 44100 Hz, stereo, s16

Change History (8)

comment:1 Changed 4 years ago by richardpl

  • Keywords id3v2 added
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from unspecified to git-master

File is not detected as tta1 at all and decodes nothing useful.

comment:2 Changed 4 years ago by richardpl

  • Summary changed from no id3v2 metadata detected for a .tta audio file to unrecognised tta file wile with id3v2 tags at begining

comment:3 Changed 4 years ago by richardpl

  • Summary changed from unrecognised tta file wile with id3v2 tags at begining to unrecognised tta file with id3v2 tags at begining

comment:4 Changed 4 years ago by michael

the complete decoding failure is a regression since 55121f3fa92901a1917f035df534e8caa82e4f71

Version 1, edited 4 years ago by michael (previous) (next) (diff)

comment:5 Changed 4 years ago by michael

detection failure without .tta extension is caused by PROBE_BUF_MAX being too small

comment:6 Changed 4 years ago by cyril

Maybe it would be more efficient when detecting ID3v2 tag to jump over ID3v2 content before starting the actual detection procedure. As ID3v2 tag are put before actual file content, it just add useless gibberish for the detection procedure.

comment:7 Changed 4 years ago by cehoyos

  • Keywords id3 tta regression added; id3v2 removed
  • Priority changed from normal to important

comment:8 Changed 4 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Paul B Mahol in 369684f.

Note: See TracTickets for help on using tickets.