Opened 4 years ago

Closed 4 years ago

#2544 closed defect (duplicate)

#error "Threading is enabled, but there is no implementation of atomic operations available"

Reported by: ami_stuff Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

I get this on mingw32 with git head:

$ make
CC      libavutil/atomic.o
libavutil/atomic.c:101:2: error: #error "Threading is enabled, but there is no implementation of atomic operations available"
make: *** [libavutil/atomic.o] Error 1

Change History (2)

comment:1 Changed 4 years ago by ami_stuff

#define HAVE_PTHREADS 0
#define HAVE_W32THREADS 1
#define HAVE_OS2THREADS 0

#define HAVE_THREADS 1

comment:2 Changed 4 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #2363.

Note: See TracTickets for help on using tickets.