Opened 4 years ago

Closed 4 years ago

#2509 closed defect (invalid)

Bigger MOOV headers regression

Reported by: zimbatm Owned by:
Priority: normal Component: avformat
Version: git-master Keywords:
Cc: jonas@pfenniger.name Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:

FFmpeg's mp4 moov header is almost twice as big as when produced with MP4Box in some cases. I'm trying to hunt down why it's the case, esp. because it hasn't always been the case.

How to reproduce:

# NOTE: big-header-video.mp4 got cut from a larger 2h file
% wget http://ffmpeg-debug.s3.amazonaws.com/big-header-video.mp4
% ffmpeg -i big-header-video.mp4 -acodec copy -vcodec copy ffmpeg.mp4

See https://gist.github.com/zimbatm/5473549 for the details on the investigation. It's a little bit mixed up because I didn't really know what I was looking for.

I am still investigating the issue, please bear with me.

Change History (6)

comment:1 Changed 4 years ago by zimbatm

  • Cc jonas@pfenniger.name added
  • Version changed from unspecified to git-master

comment:2 Changed 4 years ago by zimbatm

  • Component changed from undetermined to avformat

comment:3 Changed 4 years ago by cehoyos

To make this a valid ticket, please provide the failing command line together with the complete, uncut console output.

comment:4 Changed 4 years ago by zimbatm

Here is how to reproduce the problem:

wget http://ffmpeg-debug.s3.amazonaws.com/1050-moov-header-size/moov-header-sample.mp4
ffmpeg -i moov-header-sample.mp4 -acodec copy -vcodec copy -y ffmpeg.mp4

I don't think that any compilation options make a difference and I can reproduce it on Linux and OSX.

After fc09bf57a60d4c4a6d339b204b3282337067c06d the moov header size is 1.5x bigger than before.

comment:5 Changed 4 years ago by cehoyos

Please post the failing command line together with the complete, uncut console output to make this a valid ticket.

comment:6 Changed 4 years ago by michael

  • Reproduced by developer set
  • Resolution set to invalid
  • Status changed from new to closed

Please see -chunk_duration and -chunk_size. For example -chunk_duration 500k will decrease the moov size from 7808 to 4800

Note: See TracTickets for help on using tickets.