Opened 5 years ago

Closed 5 years ago

#2488 closed defect (duplicate)

ffmpeg seems not creating standard compliance subtitle streams in MOV files

Reported by: Nick Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: mov
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

During some tests for ticket#2431 I noticed that subtitle streams with special characters in MOV files are not displayed correctly in VLC 2.0.6. Therefore I opened a ticket in VLC bug tracker (ticket#8450).
(In other media players like SMPlayer and XBMC it works fine.)

My test files are encoded with command line:

ffmpeg -i input.mp4 -sub_charenc ISO-8859-1 -i subtitle_test.srt -map 0:v -map 0:a -c copy -map 1 -c:s:0 mov_text -metadata:s:s:0 language=ger output_imported_subtitle.mov

ffmpeg -i input.mp4 -sub_charenc ISO-8859-1 -i subtitle_test.srt -map 0:v -map 0:a -c copy -map 1 -c:s:0 mov_text -metadata:s:s:0 language=ger output_imported_subtitle.mp4

...using a Windows build of ffmpeg:
http://ffmpeg.zeranoe.com/builds/win32/static/ffmpeg-20130418-git-ee94362-win32-static.7z

So far I know, for subtitles in "MOV" the "3GPP Timed Text specification" should be used!
See also:
https://developer.apple.com/library/mac/#documentation/QuickTime/qtff/QTFFChap3/qtff3.html
http://en.wikipedia.org/wiki/MPEG-4_Part_17
http://mpeg.chiariglione.org/standards/mpeg-4/streaming-text-format
3GPP TS 26.245 Specification:
http://www.3gpp.org/ftp/Specs/archive/26_series/26.245/26245-600.zip

Another problem for MP4 files was solved with VLC tracker ticket#8450 but for the initial problem with subtitle streams in MOV files I get as answer:
"[...] the file is not encoded correctly. The FFmpeg muxer must be at fault here."
and
"Your sample is NOT using 3GPP Timed Text."

In MP4 files created by ffmpeg I can found the subtitle mark "tx3g" (for "3GPP Timed Text") but in MOV files I cannot find this mark!
Does ffmpeg using a fully standard compliance format and mark for subtitle streams in MOV files?


tested also with the last build of VLC:
http://nightlies.videolan.org/build/win32/vlc-2.1.0-20130420-0005/vlc-2.1.0-git-20130420-0005-win32.zip
(this build includes MP4 subtitle language code <0x400 detection bugfix already)

For more details see also:
https://trac.videolan.org/vlc/ticket/8450

Attachments (4)

output_imported_subtitle.mov (483.2 KB) - added by Nick 5 years ago.
output_imported_subtitle.mp4 (483.0 KB) - added by Nick 5 years ago.
subtitle_test.srt (693 bytes) - added by Nick 5 years ago.
VLC_2.0.6_mov_subtitle_bug.png (59.0 KB) - added by Nick 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by Nick

Changed 5 years ago by Nick

Changed 5 years ago by Nick

Changed 5 years ago by Nick

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords mov added; MOV sub srt removed
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of ticket #1845.

Note: See TracTickets for help on using tickets.