Opened 6 years ago

Closed 6 years ago

#2479 closed enhancement (fixed)

mov file with two edit list entries

Reported by: DEgITx Owned by:
Priority: wish Component: avformat
Version: git-master Keywords: mov
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

I checked it on 0.12 and current git versions. (with ffplay)
avformat_open_input() returns error -1094995529 (AVERROR_INVALIDDATA FFERRTAG( 'I','N','D','A')) on this file
VLC can open and play this.

Change History (4)

comment:2 Changed 6 years ago by cehoyos

  • Component changed from avcodec to avformat
  • Keywords mov added
  • Priority changed from normal to wish
  • Reproduced by developer set
  • Status changed from new to open
  • Summary changed from Error on avformat_open_input() with this file to mov file with two edit list entries
  • Type changed from defect to enhancement
$ ffmpeg -i M_error.mp4
ffmpeg version N-52234-g99818ac Copyright (c) 2000-2013 the FFmpeg developers
  built on Apr 18 2013 14:13:13 with gcc 4.7 (SUSE Linux)
  configuration: --enable-gpl --disable-indev=jack
  libavutil      52. 26.100 / 52. 26.100
  libavcodec     55.  2.100 / 55.  2.100
  libavformat    55.  2.100 / 55.  2.100
  libavdevice    55.  0.100 / 55.  0.100
  libavfilter     3. 56.103 /  3. 56.103
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  3.100 / 52.  3.100
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x2a20fa0] multiple edit list entries, a/v desync might occur, patch welcome
    Last message repeated 1 times
[mov,mp4,m4a,3gp,3g2,mj2 @ 0x2a20fa0] error reading header: -1094995529
M_error.mp4: Invalid data found when processing input
$ mplayer -demuxer mov M_error.mp4
MPlayer SVN-r36171-4.7 (C) 2000-2013 MPlayer Team

Playing M_error.mp4.
ISO: File Type Major Brand: ISO/IEC 14496-1 (MPEG-4 system) v2
Quicktime/MOV file format detected.
[mov] Video stream found, -vid 0
[mov] Audio stream found, -aid 1
VIDEO:  [avc1]  512x384  24bpp  25.000 fps    0.0 kbps ( 0.0 kbyte/s)
Load subtitles in ./
==========================================================================
Opening video decoder: [ffmpeg] FFmpeg's libavcodec codec family
libavcodec version 55.2.100 (internal)
Selected video codec: [ffh264] vfm: ffmpeg (FFmpeg H.264)
==========================================================================
==========================================================================
Opening audio decoder: [ffmpeg] FFmpeg/libavcodec audio decoders
AUDIO: 44100 Hz, 2 ch, floatle, 1411.2 kbit/50.00% (ratio: 176400->352800)
Selected audio codec: [ffaac] afm: ffmpeg (FFmpeg AAC (MPEG-2/MPEG-4 Audio))
==========================================================================
AO: [alsa] 44100Hz 2ch floatle (4 bytes per sample)
Starting playback...
Movie-Aspect is undefined - no prescaling applied.
VO: [vdpau] 512x384 => 512x384 Planar YV12
Movie-Aspect is 1.33:1 - prescaling to correct movie aspect.
VO: [vdpau] 512x384 => 512x384 Planar YV12
A:   4.2 V:   4.2 A-V:  0.000 ct:  0.023 107/107  2%  0%  0.2% 0 0

Exiting... (Quit)

comment:3 Changed 6 years ago by terran

This appears to be fixed in 2.1 as I was not able to reproduce it. Reproducible in 2.0.1.

comment:4 Changed 6 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Thierry Foucu, related to ticket #1378.

Note: See TracTickets for help on using tickets.