Opened 6 years ago

Closed 6 years ago

#2353 closed defect (fixed)

Failing to decode MJPEG

Reported by: alina@vicon.co.il Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: mjpeg regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

Summary of the bug:
Failing to decode JPEG frames. It happens on a particular JPEG frames (example clip and file is attached). Windows preview and IPP have no problem decoding the frames. Ffmpeg older versions (a year ago) also decoded correcly. But the new version, produce a broken pricture.

ffmpeg version: 1.1.3
How to reproduce:
% ffplay -i Vicon.mkv
% ffplay -i Vicon.jpg

Here are part of the error I recieve when running ffplay:
ffplay version 1.1.3 Copyright (c) 2003-2013 the FFmpeg developers

built on Mar 3 2013 01:57:34 with gcc 4.7.2 (GCC)
configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-avisynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enable-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libgsm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --enable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --enable-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable-libxavs --enable-libxvid --enable-zlib
libavutil 52. 13.100 / 52. 13.100
libavcodec 54. 86.100 / 54. 86.100
libavformat 54. 59.106 / 54. 59.106
libavdevice 54. 3.102 / 54. 3.102
libavfilter 3. 32.100 / 3. 32.100
libswscale 2. 1.103 / 2. 1.103
libswresample 0. 17.102 / 0. 17.102
libpostproc 52. 2.100 / 52. 2.100

[AVIOContext @ 02dbe000] Statistics: 33038 bytes read, 0 seeks
[mjpeg @ 02db8f00] marker=d8 avail_size_in_buf=33036
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=dd avail_size_in_buf=33034
[mjpeg @ 02db8f00] restart interval: 1
[mjpeg @ 02db8f00] marker parser used 4 bytes (32 bits)
[mjpeg @ 02db8f00] marker=db avail_size_in_buf=33028
[mjpeg @ 02db8f00] index=0
[mjpeg @ 02db8f00] qscale[0]: 6
[mjpeg @ 02db8f00] index=1
[mjpeg @ 02db8f00] qscale[1]: 13
[mjpeg @ 02db8f00] marker parser used 132 bytes (1056 bits)
[mjpeg @ 02db8f00] marker=c4 avail_size_in_buf=32894
[mjpeg @ 02db8f00] class=0 index=0 nb_codes=12
[mjpeg @ 02db8f00] class=1 index=0 nb_codes=251
[mjpeg @ 02db8f00] class=0 index=1 nb_codes=12
[mjpeg @ 02db8f00] class=1 index=1 nb_codes=251
[mjpeg @ 02db8f00] marker parser used 418 bytes (3344 bits)
[mjpeg @ 02db8f00] marker=c0 avail_size_in_buf=32474
[mjpeg @ 02db8f00] sof0: picture: 704x544
[mjpeg @ 02db8f00] component 0 2:1 id: 0 quant:0
[mjpeg @ 02db8f00] component 1 1:1 id: 1 quant:1
[mjpeg @ 02db8f00] component 2 1:1 id: 2 quant:1
[mjpeg @ 02db8f00] pix fmt id 21111100
[mjpeg @ 02db8f00] marker parser used 17 bytes (136 bits)
[mjpeg @ 02db8f00] escaping removed 28 bytes
[mjpeg @ 02db8f00] marker=da avail_size_in_buf=32455
[mjpeg @ 02db8f00] component: 0
[mjpeg @ 02db8f00] component: 1
[mjpeg @ 02db8f00] component: 2
[mjpeg @ 02db8f00] error count: 64
[mjpeg @ 02db8f00] error y=0 x=36
[mjpeg @ 02db8f00] marker parser used 476 bytes (3806 bits)
[mjpeg @ 02db8f00] marker=d6 avail_size_in_buf=31975
[mjpeg @ 02db8f00] restart marker: 6
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d7 avail_size_in_buf=31965
[mjpeg @ 02db8f00] restart marker: 7
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d0 avail_size_in_buf=31956
[mjpeg @ 02db8f00] restart marker: 0
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d1 avail_size_in_buf=31941
[mjpeg @ 02db8f00] restart marker: 1
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d2 avail_size_in_buf=31929
[mjpeg @ 02db8f00] restart marker: 2
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d3 avail_size_in_buf=31917
[mjpeg @ 02db8f00] restart marker: 3
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d4 avail_size_in_buf=31902
[mjpeg @ 02db8f00] restart marker: 4
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d5 avail_size_in_buf=31889
[mjpeg @ 02db8f00] restart marker: 5
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d6 avail_size_in_buf=31877
[mjpeg @ 02db8f00] restart marker: 6
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d7 avail_size_in_buf=31867
[mjpeg @ 02db8f00] restart marker: 7
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d0 avail_size_in_buf=31858
[mjpeg @ 02db8f00] restart marker: 0
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d1 avail_size_in_buf=31848
[mjpeg @ 02db8f00] restart marker: 1
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d2 avail_size_in_buf=31836
[mjpeg @ 02db8f00] restart marker: 2
[mjpeg @ 02db8f00] marker parser used 0 bytes (0 bits)
[mjpeg @ 02db8f00] marker=d3 avail_size_in_buf=31826
[mjpeg @ 02db8f00] restart marker: 3

Attachments (2)

Vicon.jpg (32.3 KB) - added by alina@vicon.co.il 6 years ago.
Example video clip with the problematic MJPEG
console_error_output.txt (856.9 KB) - added by alina@vicon.co.il 6 years ago.

Download all attachments as: .zip

Change History (5)

comment:1 Changed 6 years ago by cehoyos

  • Keywords mjpeg regression added

Changed 6 years ago by alina@vicon.co.il

Example video clip with the problematic MJPEG

Changed 6 years ago by alina@vicon.co.il

comment:2 Changed 6 years ago by cehoyos

  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from 1.1.3 to git-master

Regression since 7b8ed83 related to ticket #267.

comment:3 Changed 6 years ago by michael

  • Resolution set to fixed
  • Status changed from open to closed
Note: See TracTickets for help on using tickets.