Opened 3 years ago

Closed 6 months ago

#2337 closed defect (fixed)

Frame duplicated for AVCHD sample

Reported by: rmk Owned by:
Priority: normal Component: avformat
Version: git-master Keywords: h264 mpegts
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

ffmpeg -i gh2-50i-psf.mts -r 25 frame-%03d.jpg
ffmpeg version N-50562-g199db97 Copyright (c) 2000-2013 the FFmpeg developers

built on Mar 8 2013 08:33:32 with llvm-gcc 4.2.1 (LLVM build 2336.11.00)
configuration:
libavutil 52. 18.100 / 52. 18.100
libavcodec 54. 92.100 / 54. 92.100
libavformat 54. 63.104 / 54. 63.104
libavdevice 54. 3.103 / 54. 3.103
libavfilter 3. 42.103 / 3. 42.103
libswscale 2. 2.100 / 2. 2.100
libswresample 0. 17.102 / 0. 17.102

Input #0, mpegts, from 'gh2-50i-psf.mts':

Duration: 00:00:01.38, start: 0.710178, bitrate: 46737 kb/s
Program 1

Stream #0:0[0x1011]: Video: h264 (High) (HDMV / 0x564D4448), yuv420p, 1920x1080 [SAR 1:1 DAR 16:9], 25 fps, 50 tbr, 90k tbn, 50 tbc
Stream #0:1[0x1100]: Audio: ac3 (AC-3 / 0x332D4341), 48000 Hz, stereo, fltp, 192 kb/s
Stream #0:2[0x1200]: Subtitle: hdmv_pgs_subtitle ([144][0][0][0] / 0x0090)

Output #0, image2, to 'frame-%03d.jpg':

Metadata:

encoder : Lavf54.63.104
Stream #0:0: Video: mjpeg, yuvj420p, 1920x1080 [SAR 1:1 DAR 16:9], q=2-31, 200 kb/s, 90k tbn, 25 tbc

Stream mapping:

Stream #0:0 -> #0:0 (h264 -> mjpeg)

Press [q] to stop, ? for help
frame= 35 fps=0.0 q=0.0 Lsize=N/A time=00:00:01.40 bitrate=N/A dup=1 drop=0
video:5872kB audio:0kB subtitle:0 global headers:0kB muxing overhead -100.000366%

Sample is the same as for ticket 2336. It is a film of a wheel spinning with more or less constant speed so all frames differ. The result is the same with or without using the -r option for the output (just tried that because of Carl's feedback to 2336).

Change History (2)

comment:1 Changed 3 years ago by cehoyos

If there is an issue, ticket #2324 may describe the same problem.

comment:2 Changed 6 months ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords h264 mpegts added
  • Resolution set to fixed
  • Status changed from new to closed
  • Version changed from unspecified to git-master

This was fixed by Michael in 1e5271a9fd6ddcceb083f2185a4bbd8d44c9a813 - see ticket #2143.

Note: See TracTickets for help on using tickets.