Opened 7 years ago

Closed 4 years ago

#231 closed defect (fixed)

ffplay freezes with date -s in linux

Reported by: sahandeva Owned by: michael
Priority: normal Component: ffplay
Version: git-master Keywords:
Cc: cus@passwd.hu Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

While playing a video clip in ffplay, setting system time in linux by "date -s" freezes video playback while audio seems to be playing.

System Ubuntu 10.04 LTS x86_64
ffmpeg recent (20/50/2011) git pulled

Does it has some thing to do with core ffmpeg

Change History (7)

comment:1 follow-up: Changed 7 years ago by cehoyos

  • Priority changed from critical to minor
  • Reproduced by developer set
  • Status changed from new to open

Video stops playing (esp, if the time is set back), but I cannot reproduce a freeze.

comment:2 in reply to: ↑ 1 Changed 7 years ago by sahandeva

Replying to cehoyos:

Video stops playing (esp, if the time is set back), but I cannot reproduce a freeze.

Yes video stops playing but the audio does continue to play.

Wondering weather this is localized to ffplay implementation of PTS - DTS bounded to system clock or ffmpeg specific.

Checked the same scenario with VLC which perfectly plays video + audio irrespective of the system time modifications.

Please shed some light on this as implementation of my case require system time modification (using NTP)to be not effective on ffmpeg playback.

comment:3 Changed 7 years ago by saste

This is related to the implementation of av_gettime(void) in libavformat.

Read also the thread:
http://thread.gmane.org/gmane.comp.video.ffmpeg.devel/101431/focus=101434

Work in this area is very welcome.

comment:4 Changed 7 years ago by saste

  • Priority changed from minor to normal

Increased priority level to "normal", indeed this is not only a bug in ffplay but a defect in libavformat.

comment:5 follow-up: Changed 7 years ago by michael

Do we want to do thread locking in av_gettime() ? if so that shouldnt be hard to workaround

comment:6 in reply to: ↑ 5 Changed 7 years ago by sahandeva

Replying to michael:

Do we want to do thread locking in av_gettime() ? if so that shouldnt be hard to workaround

I didn't get you.

Is this have some thing to do with way I use libavformat. Please elaborate as I m not well versed.

comment:7 Changed 4 years ago by cus

  • Cc cus@passwd.hu added
  • Resolution set to fixed
  • Status changed from open to closed

I guess this is fixed with the latest av_gettime_relative patches in commit 0ca0b4c29cf750cbb15732cddbe16723a66afda8.

Note: See TracTickets for help on using tickets.