Opened 5 years ago

Closed 5 years ago

#2303 closed defect (fixed)

Protocol not found when input file name contains a comma

Reported by: khali Owned by:
Priority: important Component: avformat
Version: git-master Keywords: protocol regression
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: no

Description

When input file name contains a comma, ffmpeg and ffprobe choke with error message:
Protocol not found

% ffprobe a,b.mpg 
ffprobe version 1.0.4 Copyright (c) 2007-2012 the FFmpeg developers
  built on Feb 10 2013 19:01:53 with gcc 4.6 (SUSE Linux)
  configuration: --shlibdir=/usr/lib64 --prefix=/usr --mandir=/usr/share/man --libdir=/usr/lib64 --enable-shared --disable-static --enable-debug --disable-stripping --extra-cflags='-fmessage-length=0 -O2 -Wall -D_FORTIFY_SOURCE=2 -fstack-protector -funwind-tables -fasynchronous-unwind-tables -g -fPIC -I/usr/include/gsm' --enable-gpl --enable-x11grab --enable-version3 --enable-pthreads --enable-avfilter --enable-libpulse --enable-libvpx --enable-libopus --enable-libass --enable-libmp3lame --enable-libvorbis --enable-libtheora --enable-libspeex --enable-libxvid --enable-libx264 --enable-libschroedinger --enable-libgsm --enable-libopencore-amrnb --enable-libopencore-amrwb --enable-postproc --enable-libdc1394 --enable-librtmp --enable-libfreetype --enable-avresample --enable-libtwolame
  libavutil      51. 73.101 / 51. 73.101
  libavcodec     54. 59.100 / 54. 59.100
  libavformat    54. 29.104 / 54. 29.104
  libavdevice    54.  2.101 / 54.  2.101
  libavfilter     3. 17.100 /  3. 17.100
  libswscale      2.  1.101 /  2.  1.101
  libswresample   0. 15.100 /  0. 15.100
  libpostproc    52.  0.100 / 52.  0.100
a,b.mpg: Protocol not found

Same with the latest build from the git repository:

% ffmpeg -i a,b.mpg 
ffmpeg version N-50294-gbb7bc34 Copyright (c) 2000-2013 the FFmpeg developers
  built on Feb 25 2013 09:50:51 with gcc 4.6 (SUSE Linux)
  configuration: --prefix=/opt/ffmpeg --enable-shared --enable-libmp3lame --enable-libxvid --enable-postproc --enable-gpl --enable-x11grab --enable-avfilter --enable-version3 --enable-libx264 --enable-pthreads --enable-libvorbis --enable-libtheora
  libavutil      52. 17.103 / 52. 17.103
  libavcodec     54. 92.100 / 54. 92.100
  libavformat    54. 63.100 / 54. 63.100
  libavdevice    54.  3.103 / 54.  3.103
  libavfilter     3. 41.100 /  3. 41.100
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
a,b.mpg: Protocol not found

I know that colon is used to specify the protocol in file names, but I am not aware of comma having any special meaning in this context. I couldn't find any reference to that in the manual page either.

A workaround is to add an explicit protocol: file:a,b.mpg. But I don't think I should have to do that.

Change History (2)

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords regression added; comma removed
  • Priority changed from minor to important
  • Reproduced by developer set
  • Status changed from new to open
  • Version changed from 1.0.4 to git-master

Regression since 58030fc

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Fixed by Nicolas.

Note: See TracTickets for help on using tickets.