Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#230 closed defect (fixed)

regression with tiff flate

Reported by: ami_stuff Owned by:
Priority: important Component: avcodec
Version: git-master Keywords: regression tif roundup
Cc: Blocked By:
Blocking: Reproduced by developer: yes
Analyzed by developer: yes

Description

the file comes from issue 1419

C:\>ffmpeg -i Test_Flate_8bpp.tif
ffmpeg version git-N-30011-gb4bcd1e, Copyright (c) 2000-2011 the FFmpeg develope
rs
  built on May 18 2011 04:36:23 with gcc 4.5.3
  configuration: --enable-gpl --enable-version3 --enable-memalign-hack --enable-
runtime-cpudetect --enable-avisynth --enable-bzlib --enable-frei0r --enable-libo
pencore-amrnb --enable-libopencore-amrwb --enable-libfreetype --enable-libgsm --
enable-libmp3lame --enable-libopenjpeg --enable-librtmp --enable-libschroedinger
 --enable-libspeex --enable-libtheora --enable-libvorbis --enable-libvpx --enabl
e-libx264 --enable-libxavs --enable-libxvid --enable-zlib --pkg-config=pkg-confi
g
  libavutil    51.  2. 1 / 51.  2. 1
  libavcodec   53.  6. 0 / 53.  6. 0
  libavformat  53.  1. 0 / 53.  1. 0
  libavdevice  53.  0. 0 / 53.  0. 0
  libavfilter   2.  5. 0 /  2.  5. 0
  libswscale    0. 14. 0 /  0. 14. 0
  libpostproc  51.  2. 0 / 51.  2. 0
[tiff @ 02350780] Palette met but this is not palettized format
[image2 @ 02350280] Could not find codec parameters (Video: tiff)
Test_Flate_8bpp.tif: could not find codec parameters

Attachments (1)

Test_Flate_8bpp.tif (375.2 KB) - added by ami_stuff 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by ami_stuff

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avcodec
  • Keywords regression added
  • Priority changed from normal to important
  • Status changed from new to open
  • Version changed from unspecified to git-master

comment:2 Changed 5 years ago by saste

  • Analyzed by developer set
  • Reproduced by developer set
  • Resolution set to fixed
  • Status changed from open to closed

Fixed in Libav, and pulled in commit:

commit 034fc7bf129152b94958f4b74b9c81590350ce59
Merge: d1adad3 9bbd6a4
Author: Michael Niedermayer <michaelni@gmx.at>
Date:   Wed May 25 06:32:23 2011 +0200

    Merge remote-tracking branch 'qatar/master'
    
    * qatar/master: (22 commits)
[...]
      tiff: set palette in the context when specified in TIFF_PAL tag
[...]

Original commit was:

commit dea58b6f978032253c263233ea0d4dec6215fe57
Author: Stefano Sabatini <stefano.sabatini-lala@poste.it>
Date:   Tue May 24 01:17:25 2011 +0200

    tiff: set palette in the context when specified in TIFF_PAL tag
    
    Fix regression with palette data. Since image initialization has been
    moved after tag parsing, palette need to be specified in the context,
    and then copied to the allocated image in init_image().
    
    In particular, fix trac issue #230, file Test_Flate_8bpp.tif.

comment:3 Changed 5 years ago by cehoyos

  • Keywords tif added

comment:4 Changed 4 years ago by cehoyos

  • Keywords roundup added
Note: See TracTickets for help on using tickets.