Opened 4 years ago

Closed 4 years ago

Last modified 19 months ago

#2286 closed defect (duplicate)

Crash when trying to capture camera / libx264

Reported by: async Owned by:
Priority: important Component: undetermined
Version: unspecified Keywords: crash
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

Hi,

ffmpeg crashes whenever I try to execute the following command-line:

ffmpeg -y -f dshow -i video="Integrated Webcam" -vcodec libx264 -pix_fmt yuv420p output.mkv

OS:
reproduced on Windows 7 & 8 64 bits
Build:
Feb 17 2013 02:47:14 with gcc 4.7.2 (GCC)

Note:
It works fine with build Mar 25 2012 20:28:42 with gcc 4.6.2

Thank You

Attachments (1)

ffmpeg-20130220-094346.log (5.6 KB) - added by async 4 years ago.
Report

Download all attachments as: .zip

Change History (7)

comment:1 Changed 4 years ago by cehoyos

  • Component changed from FFmpeg to undetermined
  • Keywords crash added; Windows 7/8 64 bits removed
  • Priority changed from critical to important

Does it also crash if you do not use an external library (libx264) but -vcodec mpeg4?
Please add the complete console output to make this a valid ticket.

Changed 4 years ago by async

Report

comment:2 Changed 4 years ago by async

Using command-line
ffmpeg -y -f dshow -i video="Integrated Webcam" -vcodec mpeg4 -r 25 output.mpg
works fine

comment:3 Changed 4 years ago by cehoyos

Does the following also crash?
$ ffmpeg -f lavfi -i color -t 10 out.mp4

Version 0, edited 4 years ago by cehoyos (next)

comment:4 Changed 4 years ago by async

Yes,
ffmpeg -f lavfi -i color -t 10 -vcodec libx264 out.mp4
as well as
ffmpeg -f lavfi -i color -t 10 out.mp4
also crashes

comment:5 Changed 4 years ago by cehoyos

  • Resolution set to duplicate
  • Status changed from new to closed

Thank you for testing, this is a duplicate of ticket #2284

comment:6 Changed 19 months ago by rogerdpack

OK #2884 was fixed so this should be as well, if not please post back. Thanks!

Note: See TracTickets for help on using tickets.