Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#2272 closed defect (fixed)

converted swf file can't play audio when played in Adobe flash player

Reported by: hxuanyu Owned by:
Priority: important Component: avformat
Version: git-master Keywords: swf regression
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

This issue can be reproduced on both latest Zeranoe build and Linux build.

I used ffmpeg command: ffmpeg.exe -i input.mp4 out.swf to convert a mp4 file into a swf file.

Then the generated swf file when played in Adobe flash player, couldn't stream audio. But the same file can stream audio correctly when played in VLC player.

I tried different versions of Zeranoe build and found that the first version that has this issue is ffmpeg-git-1eabd71-win32-static, which was release in 07 May 2012.

The source file I used to convert is here: https://dl.dropbox.com/u/7854771/big_buck_bunny.mp4

Attachments (1)

log.txt (6.0 KB) - added by hxuanyu 5 years ago.
ffmpeg console output

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by hxuanyu

ffmpeg console output

comment:1 Changed 5 years ago by cehoyos

  • Component changed from undetermined to avformat
  • Keywords regression added; encode removed
  • Status changed from new to open
  • Version changed from unspecified to git-master

Regression since f095391 / 620b88a

comment:2 Changed 5 years ago by cehoyos

  • Resolution set to fixed
  • Status changed from open to closed

Should be fixed, thank you for the report!

comment:3 Changed 5 years ago by michael

The problem was that av_get_audio_frame_duration() doesnt support mp3, so it did not set the correct value.

Note: See TracTickets for help on using tickets.