Opened 5 years ago

Closed 5 years ago

#2238 closed defect (invalid)

ffplay: add SDL_AUDIO_FREQUENCY variable

Reported by: ami_stuff Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

for some reason (maybe hardware drive or some bug in libsdl) audio frequencies > than 48000 does not play correctly on my system with ffplay, so I would like to request env variable where I could set max freq which would be allowed for ffplay to use (for example 48000).

Change History (5)

comment:1 follow-up: Changed 5 years ago by Cigaes

Adding a feature to work around an unknown problem, possibly in other software, does not seem like a sane idea. You should at the very least make sure whether this is a hardware, driver, SDL or ffmpeg bug.

comment:2 in reply to: ↑ 1 ; follow-up: Changed 5 years ago by ami_stuff

Replying to Cigaes:

Adding a feature to work around an unknown problem, possibly in other software, does not seem like a sane idea. You should at the very least make sure whether this is a hardware, driver, SDL or ffmpeg bug.

since I have AC'97 (integrated) sound card then I'm probably limited to 96kHz, so mentioned variable would fix a problem for me

(I can reproduce the same problem with WinAMP as well with selected DirectSound? output)

http://en.wikipedia.org/wiki/AC%2797

comment:3 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by Cigaes

Replying to ami_stuff:

since I have AC'97 (integrated) sound card then I'm probably

I do not feel that "probably" is enough to warrant work on such a feature.

limited to 96kHz, so mentioned variable would fix a problem for me

I just tried: here, ffplay can perfectly well play audio beyond the capabilities of the hardware.

(I can reproduce the same problem with WinAMP as well with selected DirectSound? output)

That confirms that it is not a ffplay bug.

Until you can confirm what exactly is the problem, implementing anything would be shooting in the dark, that is not a proper way of maintaining software.

comment:4 in reply to: ↑ 3 Changed 5 years ago by ami_stuff

Replying to Cigaes:

I just tried: here, ffplay can perfectly well play audio beyond the capabilities of the hardware.

Did you test on Windows (DirectSound?)?

comment:5 Changed 5 years ago by ami_stuff

  • Resolution set to invalid
  • Status changed from new to closed

I can get a correct audio output for freq > 48kHz when I browse in Window's explorer (after running FFplay), so there is a sound of "click" generated by Windows and this releases playback in FFplay :/

Note: See TracTickets for help on using tickets.