Opened 5 years ago

Closed 5 years ago

#2195 closed defect (invalid)

ffplay: "ignoring extra planes" message repeated 255 times for iff ham8 with masking

Reported by: ami_stuff Owned by:
Priority: normal Component: undetermined
Version: unspecified Keywords:
Cc: Blocked By:
Blocking: Reproduced by developer: no
Analyzed by developer: no

Description

this slows down decoding a lot

C:\>ffplay peterface_ham8.iff
ffplay version N-49268-ge9d443c Copyright (c) 2003-2013 the FFmpeg developers
  built on Jan 24 2013 23:27:01 with gcc 4.7.2 (GCC)
  configuration: --enable-gpl --enable-version3 --disable-w32threads --enable-av
isynth --enable-bzlib --enable-fontconfig --enable-frei0r --enable-gnutls --enab
le-libass --enable-libbluray --enable-libcaca --enable-libfreetype --enable-libg
sm --enable-libmp3lame --enable-libopencore-amrnb --enable-libopencore-amrwb --e
nable-libopenjpeg --enable-libopus --enable-librtmp --enable-libschroedinger --e
nable-libspeex --enable-libtheora --enable-libtwolame --enable-libvo-aacenc --en
able-libvo-amrwbenc --enable-libvorbis --enable-libvpx --enable-libx264 --enable
-libxavs --enable-libxvid --enable-zlib
  libavutil      52. 15.103 / 52. 15.103
  libavcodec     54. 90.100 / 54. 90.100
  libavformat    54. 61.104 / 54. 61.104
  libavdevice    54.  3.102 / 54.  3.102
  libavfilter     3. 33.100 /  3. 33.100
  libswscale      2.  2.100 /  2.  2.100
  libswresample   0. 17.102 /  0. 17.102
  libpostproc    52.  2.100 / 52.  2.100
[iff @ 026588c0] Estimating duration from bitrate, this may be inaccurate
Input #0, iff, from 'peterface_ham8.iff':
  Duration: N/A, bitrate: N/A
    Stream #0:0: Video: iff_ilbm (ILBM / 0x4D424C49), rgb0, 320x256, SAR 44:44 D
AR 5:4, 90k tbr, 90k tbn, 90k tbc
Ignoring extra planes beyond 8
    Last message repeated 255 timesrepeated 25=    0KB sq=    0B4 times
Frame changed from size:0x0 to size:320x256
-9223372036854775808.00 A-V:  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/
   1.66 A-V:  0.000 fd=   0 aq=    0KB vq=    0KB sq=    0B f=0/0

Attachments (1)

peterface_ham8.iff (54.0 KB) - added by ami_stuff 5 years ago.

Download all attachments as: .zip

Change History (2)

Changed 5 years ago by ami_stuff

comment:1 Changed 5 years ago by ami_stuff

  • Resolution set to invalid
  • Status changed from new to closed

actually it's like 1.4s (-loglevel quiet) vs 1.8s when I test ffplay with "-autoexit", so maybe acceptable. the huge slowdown I noticed was probably caused by winuae <-> win task priorities or something.

Note: See TracTickets for help on using tickets.